Newlines not trimmed from description when converting from email

RESOLVED FIXED in 1.0b1

Status

Calendar
Lightning Only
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Laurens, Assigned: martinschroeder)

Tracking

unspecified
1.0b1
Bug Flags:
blocking-calendar1.0 -

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 0.9pre 31-Aug-2008 21:34 PST, Thunderbird 2.0.0.16

When creating an event in the calendar by dragging an e-mail to the today-pane, the mail contents are put in the description of the event. When doing this with large mails, there is a substantial amount of white-space / newlines before the first text-part is shown.

Reproducible: Always

Steps to Reproduce:
1. Search for a larger mail, eg. a reply on something
2. drag that mail to the today-pane to create a new event for it
3. look into the description field, it has unnecessary white-space
Actual Results:  
Sometimes you won't see any description at all since the first page is filled with newlines and white-space.

Expected Results:  
I'd expect the description field to be trimmed at both ends (beginning and end), so there is actual text being shown, instead of only whitespace and newlines.

A simple final trim-function on the text before it is put into place?

Comment 1

9 years ago
This may be the same bug. I get problems under these circumstances:

Lightning 0.9 on Tbird 2.0.0.14
Caldav calendar connection to Zimbra Collaboration Suite server.

I occasionally get event invites from other person sending from Exchange 2007 that Lightning can't handle. The item is automatically added to the calendar as tentative by ZCS and from that point the entire calendar will no longer load in Lightning, resulting in empty views as well as the error below in the Error Console.

Error: malformed XML character #25
Source File:
Line: 172, Column: 61
Source Code:
DESCRIPTION:Per todayb s meeting\, this is a working session to start mergi
--------------------------------------------------------------|


The description is always the offending part of the event, but it is never the same text. This only happens with a small percentage of invites (<5%) from the users of the offending Exchange system.

The workaround is to log into ZCS, go to the calendar tab, then find and delete (and remake) the offending event item based on the error text. At that point the calandar will load again in Lightning.

Maybe there is a way to handle 'malformed xml' more gracefully and allow the rest of the calendar to load up even when one event is broken.

Updated

9 years ago
Flags: blocking-calendar1.0?
Created attachment 383759 [details] [diff] [review]
Fix - v1
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #383759 - Flags: review?(ssitter)
Flags: blocking-calendar1.0? → blocking-calendar1.0-
Summary: Malformed description when creating event from mail → Newlines not trimmed from description when converting from email
Created attachment 383761 [details] [diff] [review]
Fix - v2

This is obviously the better fix.
Attachment #383759 - Attachment is obsolete: true
Attachment #383761 - Flags: review?(ssitter)
Attachment #383759 - Flags: review?(ssitter)
(Assignee)

Updated

9 years ago
OS: Windows XP → All
Hardware: x86 → All
I did not find an email that shows the misbehavior described in comment #0.

Laurens, does the issue exists at all using a recent Lightning 1.0pre nightly test build? If yes, could you attach an example email that can be imported in Thunderbird?
(Reporter)

Comment 5

9 years ago
Hi Stefan,

I could also not reproduce the problem on shredder 3.0b3pre with lightning 1.0pre 20-jun build. It seems the problem has already been fixed.

The problem is, though, reproducable on my production system, running Thunderbird 2.0.0.21 running lightning 0.9.

But since that one isn't being developed anymore, it seems useless to keep this bug open.
(Assignee)

Comment 6

9 years ago
We use getMsgTextFromStream(...) to get the message text now, and there is following code:

// We want to remove any whitespace from the beginning and end of the string
unicodeMsgBodyStr.Trim(" \t\r\n", PR_TRUE, PR_TRUE);
(Assignee)

Comment 7

9 years ago
Fixed with bug 410050.
Assignee: philipp → mschroeder
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Attachment #383761 - Attachment is obsolete: true
Attachment #383761 - Flags: review?(ssitter)
Depends on: 410050
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.