Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 453123 - Calculation of width of float uses width of :first-letter for all letters
: Calculation of width of float uses width of :first-letter for all letters
Status: RESOLVED DUPLICATE of bug 442043
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2008-09-01 04:00 PDT by Masahiro YAMADA
Modified: 2008-09-01 05:22 PDT (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

testcase (989 bytes, text/html)
2008-09-01 04:00 PDT, Masahiro YAMADA
no flags Details

Description Masahiro YAMADA 2008-09-01 04:00:05 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-KS; rv: Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080829063055 Minefield/3.1a2pre

Calculation of width of float uses font metrics of :first-letter for all letters off its content.
caclulation of width other than :first-letter should use float's font metrics.

Reproducible: Always

Steps to Reproduce:
1.Show testcase

Actual Results:  
All lines that has same text should be displayed widh same width.

Expected Results:  
Red boxed line and Blue boxed line has incorrect width.
But, at red boxed line, when after applying :hover, its width will be correct.

Green boxed lines uses only float, not using :first-letter
Red boxed lines uses float and :first-letter. And, additionally it uses :hover that causes reflow of text.
Blue boxed lines also uses float and :first-letter, but not uses :hover.
Comment 1 Masahiro YAMADA 2008-09-01 04:00:30 PDT
Created attachment 336336 [details]
Comment 2 philippe (part-time) 2008-09-01 05:22:15 PDT

*** This bug has been marked as a duplicate of bug 442043 ***

Note You need to log in before you can comment on or make changes to this bug.