mailto: link adds an extra double quote

RESOLVED DUPLICATE of bug 258653

Status

--
minor
RESOLVED DUPLICATE of bug 258653
10 years ago
10 years ago

People

(Reporter: epcmorris, Unassigned)

Tracking

1.8 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 2.0.0.12 (20080213)

When clicking on or running a mailto: URI, the first email in the bcc parameter has a double quote (") before the at (@) symbol, resulting in the email being unsendable until it is removed.

Reproducible: Always

Steps to Reproduce:
1. Click on or type in mailto:email1@example.com?bcc=email2@example.com;email3@example.com
Actual Results:  
The addresses section looks like this:
-----------------------------------------
| To: | email1@example.com              |
| Bcc:| email2"@example.com             |
| Bcc:| email3@example.com              |
-----------------------------------------

If you try to send the email, you get a #5.1.1 bad address error, since email2"@example.com is wrong.

Expected Results:  
The addresses section to look like this:
-----------------------------------------
| To: | email1@example.com              |
| Bcc:| email2@example.com              |
| Bcc:| email3@example.com              |
-----------------------------------------

and the email to send correctly.
I've confirmed this on Linux 2.0.0.17pre (build date: "not so recent").

mailto: is in the compose code... I think the error is either in nsMsgComposeService or nsMailtoUrl, but I'm not sure which. It doesn't seem to appear fixed on trunk builds (based on fixed bug lists), but I have not tested.
Status: UNCONFIRMED → NEW
Component: General → Composition
Ever confirmed: true
OS: Windows Vista → All
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Hardware: PC → All
Version: unspecified → 1.8 Branch
Addresses shouldn't be separated with semicolon- semicolon has another meaning...

via bug 420185
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 258653
You need to log in before you can comment on or make changes to this bug.