drag and drop has wrong target in places menupopups (event.layerY support missing)

VERIFIED FIXED in Firefox 3.1b1

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: mak, Assigned: Neil Deakin)

Tracking

({regression})

Trunk
Firefox 3.1b1
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
this is a recent regression.

STR:
1. create a new profile
2. open the bookmarks menu and drag "Get bookmarks add-ons" between the two smart bookmarks (recently bookmarked and recent tags)

result:
3. the bookmark is inserted at the top

expected:
3. bookmarks is correctly inserted between smart bookmarks

regression range: 20080827031643 - 20080828034823

needs stricter range (hourly)
Flags: blocking-firefox3.1?
(Reporter)

Comment 1

10 years ago
probably regression from bug 356295, needs to be verified, cc-ing neil
Keywords: qawanted
(Reporter)

Updated

10 years ago
Keywords: qawanted
(Reporter)

Comment 2

10 years ago
so it's a target problem, we were using event.layerY, the new impl does not support it
Blocks: 453165
No longer blocks: 453165
Blocks: 453165
(Assignee)

Comment 3

10 years ago
Created attachment 336491 [details] [diff] [review]
support layerX/layerY for drag and popup events
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #336491 - Flags: superreview?(roc)
Attachment #336491 - Flags: review?(roc)
(Reporter)

Comment 4

10 years ago
another thing, we were doing aEvent.originalTarget.getAttribute("anonid") to see if we were over "scrollbutton-up" of the arrow scrollbox, now it's not working, i can't get the arrow button as originalTarget anymore
(Assignee)

Comment 5

10 years ago
(In reply to comment #4)
> another thing, we were doing aEvent.originalTarget.getAttribute("anonid") to
> see if we were over "scrollbutton-up" of the arrow scrollbox, now it's not
> working, i can't get the arrow button as originalTarget anymore

Do you have a testcase here? 'originalTarget' seems to be working for me.
(Reporter)

Comment 6

10 years ago
i don't have a test case yet, however if you dragover the scroll arrows in a places menu (the bookmarks menu for example) it should scroll. in menu.xml ondragover we do var anonid = aEvent.originalTarget.getAttribute("anonid"); this was working before, not working now
(Reporter)

Comment 7

10 years ago
target is probably the element behind the scroll button instead of the button itself
(Assignee)

Updated

10 years ago
Blocks: 453299
Attachment #336491 - Flags: superreview?(roc)
Attachment #336491 - Flags: superreview+
Attachment #336491 - Flags: review?(roc)
Attachment #336491 - Flags: review+
(Reporter)

Comment 8

10 years ago
mh, i've created a test and i see that it's working, so don't worry, layerY support is enough
(Reporter)

Updated

10 years ago
No longer blocks: 453165
(Reporter)

Updated

10 years ago
Blocks: 356295
(Assignee)

Comment 9

10 years ago
I won't be able to check this in for a few days.
Keywords: checkin-needed
(Reporter)

Updated

10 years ago
Summary: drag and drop is wrong in the bookmarks menu → drag and drop has wrong target in places menupopups (event.layerY support missing)
(Reporter)

Comment 10

10 years ago
Thank you Neil

http://hg.mozilla.org/mozilla-central/rev/0596ac47428f
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3.1? → in-testsuite+
verified fixed with hourly build:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080903113031 Minefield/3.1b1pre Firefox/3.0 ID:20080903113031
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 453761
Target Milestone: Firefox 3.1 → Firefox 3.1b1
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.