Search of local folders leaves folders showing unread messages

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: herbert.kritzer, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-02-30])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 2.0.0.16

I have a substantial local mailstore that I imported a while back from Eudora.

Whenever I do a search of my local folders, every message that was imported from Eudora ends up marked as unread (and hence, I end up with a large number of folders marked as containing unread messages). To get rid of the folders marked as unread, I have to then go through ever subfolder that is marked as unread and mark it as "folder read". If I then to another search, the messages again get marked as unread, and I have to go through the same process, which given the number of folders I have is a pain in the b**** (particularly because there is no add-in that propagates the "mark folder read" to all subfolders.

Is it possible to have the "mark folder read" function genuinely mark the messages as read in a way such that future searches do not end up showing all the messages as unread? Alternatively, if it was possible to create an add-in that work mark folders AND subfolders as read, it would be less of a problem.

Note that when I originally imported the mailstore (now several years ago), everything was marked as unread, and I went thru the individual messages and marked them as read. However, it doesn't "stick", and the search problem has existed in all the Thunderbird versions I have used.

Reproducible: Always

Steps to Reproduce:
1. Import a local mailstore from Eudora
2. Mark all messages (folders) as read
3. Search the local mailstore for some string

Actual Results:  
All imported messages are marked as unread

Expected Results:  
Messages previously marked as read remain marked as read.

Updated

9 years ago
Component: General → Migration
QA Contact: general → migration
Version: unspecified → 2.0
Bert, your issue is still here also with latest Tb 3.x?
Whiteboard: [closeme 2010-02-30]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error, please respond with to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

9 years ago
Never received notice of the 20-10-02-16 query ...

I just tried the search with 3.x, and the problem seems to have been resolved.
Resolution: INCOMPLETE → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.