wrapped text not correctly displayed

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Wei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: 2.0.0.16 (20080724)

The text email written by thunderbird 2.0.0.16 (20080724) is not correctly displayed wrapped correctly. You can see the picture here.

This is a text email that is NOT wrapped around the 80 character I set, when I see it from thunderbird windows.

http://img522.imageshack.us/my.php?image=examplezh5.png

This is the source view of the same email, as you can see, the text is wrapped correctly.

http://img511.imageshack.us/my.php?image=screenshot2fn6.png

All other text emails from other clients are all displayed wrapped correctly. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
The text should display correctly, wrapped at the number of characters I set.

Comment 1

10 years ago
Please attach your images to the bug, rather than using an outside host.
(Reporter)

Comment 2

10 years ago
Created attachment 336509 [details]
Not correctly wrapped text, written with thunderbird.
(Reporter)

Comment 3

10 years ago
Created attachment 336510 [details]
Source view of that text
(Reporter)

Comment 4

10 years ago
Created attachment 336512 [details]
Correctly wrapped text, written with kmail.
(Reporter)

Updated

10 years ago
Attachment #336509 - Attachment description: Not correctly wrapped text → Not correctly wrapped text, written with thunderbird.
(Reporter)

Comment 5

10 years ago
Created attachment 336514 [details]
Source view of the correctly wrapped email written with kmail.

Comment 6

10 years ago
Thunderbird sends by default messages with format=flowed, thus allowing the receiving e-mail client to rewrap the message to the window width when displaying. This is what appears to happen in attachment 336509 [details].

According to attachment 336514 [details], kmail does *not* use format=flowed,
therefore the message is displayed as sent.

You can set mailnews.display.disable_format_flowed_support=true to enforce strict wrapping of the message. Also, mailnews.send_plaintext_flowed=false prevents Thunderbird from adding a format=flowed attribute to your messages.

If this resolves the issue, the bug here would be INVALID as you described intended behavior.
(Reporter)

Comment 7

10 years ago
It is better to let user decide the message format, whether they want to use "flowed" or not. This "flowed" text has been there forever, and nobody came up with a GUI option to disable/enable it?

Comment 8

10 years ago
There are currently no checkboxes, etc., for those, but you can access the preferences using the Config Editor, Edit > Preferences > Advanced > General.

An enhancement request (bug 86607) is pending for adding UI elements.

Comment 9

10 years ago
Wei, was comment #7 intended to indicate that disabling flowed format resolved your issue, and that you were just wondering why there are no UI elements yet for these preferences, or is there anything else preventing us from closing this bug report?
(Reporter)

Comment 10

10 years ago
Yes, it is resolved. Thank you very much.

Comment 11

10 years ago
Marking as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.