Image viewing slow, seems to hang in fetchGlyphExtents

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Everytime I view an image just FF hangs, sometimes for over 10 seconds.

I've tried a new profile, safe mode without all extensions, and have excluded those possibilities. It is also not the webserver, I've straced that one as well, it's really firefox hanging with 50% on the (dual-core) CPU. 

When I view the process using Process Explorer, this is the stack from the firefox-thread I regularly see:

ntoskrnl.exe+0x5909
xul.dll!XRE_GetStaticComponents+0x13b5
xul.dll!XRE_GetStaticComponents+0x2d0b
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x2286
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x32b2
xul.dll!gfxASurface::GetDefaultContextFlags+0xd22c2
xul.dll!JSJ_RegisterLiveConnectFactory+0xd65
xul.dll!JSJ_RegisterLiveConnectFactory+0xe27
xul.dll!gfxTextRun::FetchGlyphExtents+0xb058
xul.dll!NS_StringCopy_P+0xce27
xul.dll!gfxWindowsPlatform::GetPrefFontEntries+0x467
xul.dll!gfxTextRun::FetchGlyphExtents+0xae5c

Sometimes it's this:

ntoskrnl.exe!ZwAssignProcessToJobObject+0x15
ntoskrnl.exe!MmCreateMdl+0x28a
hal.dll!HalClearSoftwareInterrupt+0x342
xul.dll!NS_InvokeByIndex_P+0x6303a
xul.dll!XRE_GetStaticComponents+0x2cf4
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x2286
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x32b2
xul.dll!gfxASurface::GetDefaultContextFlags+0xd22c2
xul.dll!JSJ_RegisterLiveConnectFactory+0xd65
xul.dll!JSJ_RegisterLiveConnectFactory+0xe27
xul.dll!gfxTextRun::FetchGlyphExtents+0xb058
xul.dll!NS_StringCopy_P+0xce27
xul.dll!gfxWindowsPlatform::GetPrefFontEntries+0x467
xul.dll!gfxTextRun::FetchGlyphExtents+0xae5c

Or this (this is from clicking on another tab):

ntoskrnl.exe!ZwAssignProcessToJobObject+0x15
ntoskrnl.exe!MmCreateMdl+0x28a
hal.dll!HalClearSoftwareInterrupt+0x342
xul.dll!XRE_GetStaticComponents+0x2d9d
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x2286
xul.dll!gfxTextRun::GlyphRunIterator::GetStringStart+0x32b2
xul.dll!gfxASurface::GetDefaultContextFlags+0xd22c2
xul.dll!JSJ_RegisterLiveConnectFactory+0xd65
xul.dll!JSJ_RegisterLiveConnectFactory+0xe27
xul.dll!gfxWindowsPlatform::GetPrefFontEntries+0x467
xul.dll!gfxTextRun::AdjustAdvancesForSyntheticBold+0xe1a8
xul.dll!gfxASurface::GetDefaultContextFlags+0x868cb
xul.dll!JVM_MaybeShutdownLiveConnect+0x8850
xul.dll!JVM_MaybeShutdownLiveConnect+0x88d3
xul.dll!gfxImageSurface::Format+0x323
xul.dll!gfxWindowsFontGroup::operator=+0x1777
xul.dll!gfxFontStyle::operator=+0x4e5
xul.dll!gfxPDFSurface::operator=+0xdc0f
xul.dll!gfxASurface::GetDefaultContextFlags+0xcd89a
xul.dll!gfxPlatform::IsCMSEnabled+0x7ca2
xul.dll!NS_StringSetDataRange_P+0x135d
xul.dll!NS_NewLocalFile_P+0x34a9
xul.dll!gfxTextRun::FetchGlyphExtents+0x18312

Always the fetchGlyphExtents() at the end. I have tried moving some large-ish fonts away from c:\windows\fonts, and, besides a less nice firefox interface, have experienced only *more* delays.

Anyone able to help me debug this?

Comment 1

9 years ago
What Firefox version are you using? On what Operating System? Is there any reproducible way for this bug?
(Reporter)

Comment 2

9 years ago
Heh, as if i remember the exact version after two years ;) I've got no more information than already in the bugreport, sorry. Can't remember seeing it anymore, either. Probably got fixed by an upgrade of Java...

Thank you for trying to help, though.

I'll close this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.