Adds double (or more) bookmarks when fast clicking on the "Add" button on toolbar.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Kevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Summary says all I guess, except for the fact that it only happends when adding a bookmark to the toolbar, taskbar.. workpallete, however you may call it... the always visible text/icon bookmarks. Anyways... as long as you get the fact that its not happening when you add a bookmark in your regular alt+shift+a menu. Browser lagged for a sec when i pressed add with some fast clicks, wich resulted in 2 of the same bookmarks. I tried a second time, and was able to get to up to 12 bookmarks easily with some fast clicks at once.

Reproducible: Always

Steps to Reproduce:
1.Rightclick your toolbar and click "new bookmark"
2.Add quite some data (preferably some lines with details too so it takes a bit longer to load)
3.Click on the "Add" button as fast as you can and as many as you can.
Actual Results:  
After doing step 3 you will notice that this is like a big memory leak or something... if you click fast enough you will be able to keep clicking the add button for as long as you desire. It sort of "hangs" and I was able to get as much as I wanted basicly I could go on untill im 20 years older hehe :P.

Expected Results:  
10..20..30..40..50 bookmarks at once with fast clicking the add button.

Just add 1 bookmark and either dont lagg/hang or add a double bookmark posting block.

More info more chance to a fix ;-)
So here my comp specs for some additional info.

Motherboard:  	
Asus P5B Deluxe Wi-Fi
Processor:  	
Intel Core 2 Duo E6600 2x 2.4 GHZ 4MB Cache 1GHZ/FSB
Memory: 	
Kingston HyperX 2048 DDR2 PC 6400 800 MHZ
Hard Drive: 	
2x Seagate Barracuda 320GB 16MB Cache, 1x WD 500GB 24/7 16MB Cache
Video Card: 	
Asus GeForce 8800 GTX 768MB DDR3
Monitor: 	
Samsung 226BW 22" 2ms
Sound Card: 	
Creative Sound Blaster PCI
Speakers/Headphones: 	
Cambridge Soundworks 4.1 (EAX)
Keyboard: 	
Logitech Navigator
Mouse: 	
Logitech G9
Operating System: 	
Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_rtm.040803-2158)
Duplicate of this bug: 453323
i'm unable to reproduce this on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081219 Minefield/3.2a1pre

feel free to reopen if you can reproduce this on trunk or current 3.1 beta
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

9 years ago
Windows Vista™ Ultimate (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.080425-1930)

Windows XP Professional (5.1, Build 2600) Service Pack 2
(2600.xpsp_sp2_rtm.040803-2158)

Since Beta 3.1 I am UNABLE to reproduce with both: Vista / XP Platform:
     - Server now adds and closes window directly, so no chance at being able 
     - to press the button most of the times, if you do get the chance it still
     - doesnt perform a second action.

Bug is still reproducable when using 3.0 on both the Vista and XP Platform.
Resolution: WORKSFORME → FIXED
FIXED must be used only if there's a patch attached or the patch that fixed the issue is known, in all other cases the correct choide for resolution is WORKSFORME.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.