TM: date-format-toefte hangs on windows

RESOLVED FIXED in mozilla1.9.1b1

Status

()

defect
P1
critical
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: sayrer, Assigned: brendan)

Tracking

unspecified
mozilla1.9.1b1
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

11 years ago
Posted patch fixSplinter Review
bool FASTCALL is not compatible with Nanojit's calling convention usage. Do not use bool FASTCALL, use JSBool only!

/be
Assignee: general → brendan
Status: NEW → ASSIGNED
Attachment #336561 - Flags: review?(mrbkap)
(Assignee)

Updated

11 years ago
Severity: normal → critical
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b1
Comment on attachment 336561 [details] [diff] [review]
fix

It might be good to run Taras's PRBool checker over the JS source to catch more JSVAL_ERROR_COOKIE errors.
Attachment #336561 - Flags: review?(mrbkap) → review+
(Assignee)

Comment 3

11 years ago
Fixed on tracemonkey:

http://hg.mozilla.org/tracemonkey/rev/f4909cae663d

/be
(Assignee)

Comment 4

11 years ago
Fixed on m-c:

http://hg.mozilla.org/mozilla-central/rev/f4909cae663d

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 451942

Updated

11 years ago
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.