FF crashes while visiting the resource.

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: alexander.timakov, Unassigned)

Tracking

({crash})

1.9.0 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1

http://beemp3.com/download.php?file=633446&song=Remember+Love

google put this page in the top of the results of some search request.

While opening page FF crashes (all windows and tabs) no matter - opening in a
new tab or window.

Reproducible: Always

Steps to Reproduce:
1. google: "noze mp3 download"
2. try visit the first link given (now its mentioned URL)
3.
Actual Results:  
FF crashes.

Expected Results:  
Just open the page i guess..

[****]# rpm -qa | grep flash
libflashsupport-000-0.5.svn20070904.i386
flash-plugin-10.0.0.569-release.i386
(Reporter)

Comment 1

10 years ago
OS: Fedora 9
Linux timmy.****.ru 2.6.25.14-108.fc9.i686 #1 SMP Mon Aug 4 14:08:11 EDT 2008 i686 i686 i386 GNU/Linux

I cant post report about broken link because while posting I must be on the
page wich crashes FF.
We need a stacktrace with symbols and I can not tell you how to create such a stacktrace with debug symbols because you are using a fedora build.

this is wfm with FF3.01
(Reporter)

Comment 3

10 years ago
Created attachment 336627 [details]
backtrace got from "firefox -g -d gdb"

nspluginwrapper-debuginfo wasnt installed through deps. Installed by gdb hint:
...
Missing separate debuginfo for /usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
Try: yum --enablerepo='*-debuginfo' install /usr/lib/debug/.build-id/99/6cdaccf2799470d0dbc1f2476f4227765f5f4e.debug
...
(Reporter)

Comment 4

10 years ago
'Bad guy' was a libflashplayer (rpm: flash-plugin-10.0.0.569-release.i386)
installed from adobelabs: its in a test stage there.
All works fine after installing original flash-plugin from fedora repositories.

(flash-plugin-10.0.0.569-release.i386 -> flash-plugin-9.0.124.0-release.i386.rpm)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.9.0 Branch
You need to log in before you can comment on or make changes to this bug.