Treehydra: ICE while calling walk_tree on some mozilla functions

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
10 years ago
6 months ago

People

(Reporter: benjamin, Assigned: taras.mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 336669 [details]
Failing source: nsPACMan.i.bz2

When using walk_tree on some mozilla functions:
Check../../../../src/netwerk/base/src/nsPACMan.cpp: In member function ‘nsresult nsPACMan::LoadPACFromURI(nsIURI*)’:
../../../../src/netwerk/base/src/nsPACMan.cpp:288: internal compiler error: in tree_node_structure, at tree.c:2241
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

This appears to be because we've got a C++ frontend TREE_CODE and are calling tree_node_structure on it at http://hg.mozilla.org/users/tglek_mozilla.com/dehydra-gcc/file/13479865fbc3/treehydra.c#l151

We need to be calling cp_tree_node_structure first, I think, but I'm not sure how that actually works with treehydra reflections.

I will attach preprocessed source for the file in question. To reproduce the problem, simply run the following treehydra script:

function process_cp_pre_genericize(fdecl)
{
  pretty_walk(DECL_SAVED_TREE(fdecl), 10000);
}
(Assignee)

Comment 1

10 years ago
I'm pretty sure you are right. Please test and commit.
(Reporter)

Updated

10 years ago
Depends on: 437502
(Reporter)

Updated

10 years ago
Blocks: 437502
No longer depends on: 437502
(Assignee)

Comment 2

10 years ago
Created attachment 336709 [details] [diff] [review]
avoids ICE

here is a temporary hack to avoid the ICE.
(Assignee)

Comment 3

10 years ago
implemented "correct" fix to avoid language-specific nodes. Hopefully the need for these node types wont arise until after gcc 4.3 which does away with stupid enum overloading tricks.
(Assignee)

Comment 4

10 years ago
pushed fec94ecb6278
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.