Pref: Browser/Editor Default Charset should not include cached charset

VERIFIED FIXED in M18

Status

()

P4
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: momoi, Assigned: cata)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] ETA:9/7)

(Reporter)

Description

19 years ago
** Observed with 7/12/2000 Win32 build **

In Edit | Prefs | Languages | Character Coding list,
we currently see both:

1. static list of charsets
2. Cached charsets

We should not include item #2 on this list. If you have just the 
Western Charset and then a cached item, e.g. KOI8-R, and if you 
choose KOI8-R, then the next time you start Mozilla and look
in the default charset pref, you won't see KOI8-R because
currently the cache list is not saved from session to session.

Aside from this, it is simply not correct to show cached list
items here. We want a (semi-)permanent list. Otherwise
users would be confused.

We have not had an explicit discussion of this yet but I think 
it would be better to show the entir echarset list here
rather than the limited "static" list. This last point may be
debatable and so let's hear some opinions.

Comment 1

19 years ago
Reassign jbetak's bug to ftang.
Assignee: nhotta → ftang

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
reassign to cata
Assignee: ftang → cata
Status: ASSIGNED → NEW
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Keywords: correctness, nsbeta3

Comment 3

19 years ago
Mark as nsbeta3+
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 4

18 years ago
Mark it as P4.
Priority: P3 → P4

Comment 5

18 years ago
*** Bug 44062 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

18 years ago
The work for this bug can be splitted in two:
1) Create an RDF data source branch holding all the decoders
2) Use that data source in XUL dialogs
Whiteboard: [nsbeta3+] → [nsbeta3+] ETA:9/7

Comment 7

18 years ago
2) is easy simply change 

The value of rdf in
http://lxr.mozilla.org/seamonkey/source/xpfe/components/prefwindow/resources/con
tent/pref-languages.xul
82       <menulist id="DefaultCharsetList" ref="NC:MaileditCharsetMenuRoot" 
datasources="rdf:charset-menu"
 
from "NC:MaileditCharsetMenuRoot" to the new RDF root value that you creat

(Assignee)

Comment 8

18 years ago
Failed to check in yesterday, sorry. I am almost done, I need review and then 
I'll check in today.
(Assignee)

Comment 9

18 years ago
Frank, you're right. But I wonder if there would be any other place where we 
could use this new RDF datasource branch?
(Assignee)

Comment 10

18 years ago
And all is done and checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Verified in 2000-09-11-08 Win32, Linux, and Mac build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.