Make tab previews bigger and show a smaller part of each tab

VERIFIED FIXED in Firefox 3.1b1

Status

()

enhancement
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

({polish})

Trunk
Firefox 3.1b1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

11 years ago
Posted patch patch (obsolete) — Splinter Review
We currently capture full pages and shrink them to the desired preview size. In most cases it's probably better to capture a smaller part, which in return wouldn't have to be shrunken as much.

See also bug 445458.
Assignee

Updated

11 years ago
Severity: normal → enhancement
Assignee

Comment 1

11 years ago
Posted patch patch v2 (obsolete) — Splinter Review
this is more aggressive... I'll dogfood this for a day or two and then push it to the extension users.
Attachment #336764 - Attachment is obsolete: true
Assignee

Updated

11 years ago
Duplicate of this bug: 445458
Assignee

Updated

11 years ago
Summary: Make tab previews show a smaller part of each tab → Make tab previews bigger and show a smaller part of each tab
Assignee

Comment 3

11 years ago
Posted patch patch v2Splinter Review
I was afraid that the 16:9 format would look strange and that showing only 60% of the page width wouldn't work well on some sites. My own usage doesn't confirm this, and I haven't received a single complaint from the add-on users.

The change to image/png shouldn't have been part of the previous patch, that's bug 447896.
Attachment #337322 - Attachment is obsolete: true
Attachment #337836 - Flags: review?(gavin.sharp)
Attachment #337836 - Flags: review?(gavin.sharp) → review+
Assignee

Updated

11 years ago
Keywords: checkin-needed
Assignee

Comment 4

11 years ago
pushed 6080d74a262c
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b1
Verified with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080920033605 Minefield/3.1b1pre

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080920020518 Minefield/3.1b1pre ID:20080920020518
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.