bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

For any Chinese items on Wikipedia, Firefox fails to convert Chinese scripts to its variations

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
major
VERIFIED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Zeting Liu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-09-21, URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

for any chinese page on Wikipedia, there's an option of viewing it in original(不转换), Simplified(简体), Traditional(繁體), Mainland Simplified(大陆简体),HK/Macau Traditional(港澳繁體), Singapore/Malaysia Simplified(新马简体)Taiwan Traditional(台灣正體).

Firefox can only display the original. Whatever other options you link, it reloads the page with no display difference.

IE, Safari works well under WinXP, Vista and MacOS X.

Reproducible: Always

Steps to Reproduce:
1. Open any page in Chinese Wikipedia - zh.wikipedia.org/
2. Click any option of "convert to xxx" --- Simplified(简体), Traditional(繁體), Mainland Simplified(大陆简体),HK/Macau Traditional(港澳繁體), Singapore/Malaysia Simplified(新马简体)Taiwan Traditional(台灣正體).
3. No effect
Actual Results:  
Reloads the page and (seems to) be redirected to original, can't display in pure traditional or simplified, stays what it used to display

Expected Results:  
Should be able to show the page in any of the following options:
Simplified(简体), Traditional(繁體), Mainland Simplified(大陆简体),HK/Macau Traditional(港澳繁體), Singapore/Malaysia Simplified(新马简体)Taiwan Traditional(台灣正體)

it happens every time, and Internet Explorer 7 and Safari 3 works perfectly. So it must be something wrong with Firefox.

This problem happens to Firefox both in PC and Mac!

Comment 1

10 years ago
I chould not reproduce the bug.

User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I tried to reproduce the bug on this article
http://zh.wikipedia.org/wiki/%E9%87%91

When I chose original(不转换), the "For other meanings..." line was displayed like this:
本文講述的是一種金屬元素。關於「金」的其他意思,詳見「金 (消歧义)」。
http://zh.wikipedia.org/wiki/%E9%87%91

And when I chose Simplified(简体), the same line was displayed like this:
本文讲述的是一种金属元素。关于“金”的其他意思,详见“金 (消歧义)”。
http://zh.wikipedia.org/w/index.php?title=%E9%87%91&variant=zh-hans

I found differences in quotation marks and some other characters. So I suppose they are displayed correctly.

Comment 2

9 years ago
  Zeting Liu do you still see the problem using version 3.5?
if you do, is it possible (given comment 1) that the problem is windows only?
Whiteboard: closeme 2009-09-21
-> incomplete - no reply
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.