Internal Server Error when going to http://hg.mozilla.org/

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: mcsmurf, Assigned: aravind)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
To reproduce:
1. Go to http://hg.mozilla.org/

Observe that the first three repositories are listed (actionmonkey, actionmonkey-tamarin and ast). The other repositories are not listed and above those three entries an "Internal Server Error - The server encountered an internal error or misconfiguration and was unable to complete your request. [...]" is displayed.
(Reporter)

Updated

10 years ago
Summary: Internal Server Error when goint to http://hg.mozilla.org/ → Internal Server Error when going to http://hg.mozilla.org/
Assignee: nobody → server-ops
Component: Hg: Customizations → Server Operations
QA Contact: hg.customizations → mrz
Possibly also worth noting is that I'm getting the following when trying to push to comm-central:

remote: Not trusting file /repo/hg/mozilla/comm-central/.hg/hgrc from untrusted user root, group hg_mozilla

mozilla-central seems ok
The Internal Server Error and the error in comment #1 could well be related. comm-central might come next after ast, and there is a known problem in the current hg setup that makes for problems when this kind of thing happens.

Also, not trusting the hgrc is a problem because it means hooks won't be executed, meaning no pushlog or single-head checks.

So, probably just fixing the perms on .hg/hgrc for comm-central will fix this. Longer-term, making mod_wsgi a little more flexible about this thing (using PermitStderr directive or some such) might be helpful.
(Assignee)

Comment 3

10 years ago
looking into this.
Assignee: server-ops → aravind
(Assignee)

Comment 4

10 years ago
Fixed the owners on the hgrc files, both errors should be gone now.  I am going to look for a better fix for this sometime today - either directory permissions or a cron job that scans and fixes the owners.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.