"Save & Quit" closes all windows but does not quit browser

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Timothy Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

I have Firefox in some weird, completely repeatable state, where saving on quit causes the browser to close (and successfully save) all windows, but the application doesn't quit.  I have to tell a second time to quit.

This isn't normal, but it's completely repeatable at this moment.  It would be helpful if someone could tell me what files to attach that would allow them to repeat this.  I need to continue to use Firefox to do work, so there's a risk I may break the state I've gotten it in.


Reproducible: Always

Steps to Reproduce:
1.  Quit (with save and quit)
2.  Observe that the windows are closed but the browser is not
3.  Quit again 
Actual Results:  
Quits on the second try

Expected Results:  
It should quit on the first try

I have two windows with 11 tabs each and 3 windows with one tab each.

Comment 1

9 years ago
This could be a duplicate of bug 400479.
Component: Session Restore → General
QA Contact: session.restore → general
Whiteboard: DUPEME
(Reporter)

Comment 2

9 years ago
I don't see any obvious relationship.  But I don't know anything about Firefox internals.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: DUPEME → [CLOSEME 2010-11-01]
(Reporter)

Comment 4

7 years ago
I believe this one is fixed.  Can someone else verify?

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.