Recently added bookmarks lost on Firefox exit, restart

RESOLVED DUPLICATE of bug 462366

Status

()

--
major
RESOLVED DUPLICATE of bug 462366
10 years ago
9 years ago

People

(Reporter: pieman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Any bookmark added to the Bookmarks Toolbar are lost if Firefox is exited. I can only confirm that this is for recently-added bookmarks. Performing a backup of bookmarks from the Organize Bookmarks page seems to prevent this from occurring.

Reproducible: Always

Steps to Reproduce:
1. Drag/Drop a URL from the location bar to the Bookmarks Toolbar.
2. Verify the newly-saved bookmark appears on the Bookmarks Toolbar.
3. File, Exit Firefox.
4. Start Firefox.

Actual Results:  
After re-starting Firefox, the newly-saved bookmark is no longer on the Bookmarks Toolbar.

Expected Results:  
The newly-saved bookmark should still appear on the Bookmarks Toolbar.

Performing an explicit Backup operation seems to prevent this problem. Also, it is possible that bookmarks added for more than a day before Firefox is exited also persist. (Automatic backup?)
(Reporter)

Comment 1

10 years ago
I should note that I did not like the new Bookmarks history features and am using the plugin that restores old bookmarks functionality.
Do you get this in the Firefox safemode ?
- http://kb.mozillazine.org/Safe+mode

Do you use Norton360 on your system ?
(Reporter)

Comment 3

10 years ago
I do not use Norton360. I do use Norton Anti-Virus, but this was a problem before I installed Norton.
(Reporter)

Comment 4

10 years ago
I started firefox in safe mode, disabled all add-ons, the problem still occurred.
I asked because there is a known problem with Norton360, it blocks writing to the bookmark database (bug 452469)
Can you try to create a new profile ?
http://kb.mozillazine.org/Profile_Manager
(Reporter)

Comment 6

10 years ago
I made a new test profile and the problem does not occurr with it.
Be sure that you have a backup of your bookmarks in your old profile !
Then locate your profile folder :
http://kb.mozillazine.org/Profile_folder_-_Firefox

Be sure that Firefox is closed and move this files to somewhere else :
places.sqlite, and if they exists places.sqlite-journal and/or places.sqlite-stmtjrnl 

Start Firefox with your old profile and look if your bookmarks are working.
(Reporter)

Comment 8

10 years ago
The file places.sqlite was present, places.sqlite-stmtjrnl was not. I deleted places.sqlite. This seems to have corrected the problem and correct bookmark behaviour was observed. It was a pretty big file. Have I lost anything I need to rebuild?
The places.sqlite is a sqlite database file which contains your bookmarks and history.
I told you to move it away instead of deleting because it could be broken and it would be nice to analyze it later why your got this problem.
Do you have a backup of that file ?
Component: Bookmarks & History → Places
QA Contact: bookmarks → places
(Reporter)

Comment 10

10 years ago
I still have it, but it is too large to attach to the bugzilla. I put it here:
http://www.chunderpot.com/share/places.sqlite
I would not put this into the public, this file contains your bookmarks and your whole browser history.
Keep it on your system until a developer asks for it.

Could you do a last test and put it back, to be sure that the problem is caused by this file ?
The file permissions are also ok ?
(Reporter)

Comment 12

10 years ago
The file re-appears each time firefox is started. Though I believe I was able to make the problem stop by removing that file, I have not been able to do the same thing again. The problem occurs whether or not I remove the file. This is an PC running XP and the file permissions do NOT have "read-only" or "hidden" attributes.
Removing the file will simply regenerate it since it's needed to hold history and bookmarks. Try using a completely new profile for a while (some day) and see if the problem is definately solved with that, since the db could be locked by some antispyware/antivirus software.

If it is solved with the new profile then you could upload your places.sqlite zipped WITH A PASSWORD and mail the password to a developer (me, dietrich, shawn, asaf, ...) so we can take a look at it
your old not working places.sqlite clearly...
(In reply to comment #0)
> Performing an explicit Backup operation seems to prevent this problem.

so this is a dupe of bug 462366
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462366
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.