JS problem: popup window will not close (window.close()?)

VERIFIED DUPLICATE of bug 30627

Status

()

Core
DOM: Core & HTML
P3
critical
VERIFIED DUPLICATE of bug 30627
18 years ago
18 years ago

People

(Reporter: Jonas Nagel, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Overview Description: 
I go to the above URL and login with moztest/billyboy. The filemanager tries to 
load but its never completing and following JS error appears:

Document http://www.tripod.de/hpstudio/fmframeset/index.jsp loaded successfully
JavaScript error:
 line 0: uncaught exception: [Exception... "Component does not have requested in
terface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)"  location:
 "<unknown>"]
Entry at index 0 is fahrplan.zhol.ch
Entry at index 1 is www.tripod.de
Entry at index 2 is javascript:
WEBSHELL- = 9
WEBSHELL- = 8
WEBSHELL+ = 9
Document: Done (0.39 secs)
Error loading URL javascript:

Steps to Reproduce: 
1) Go to the above URL
2) Login to tripod with l/p: moztest/billyboy
3) Filemanager should load up

Actual Results: 
The JS popup window displaying the status is staying open and shows its still 
loading while in the JS console and the browser console the JS error is 
displayed as above.

Expected Results: 
Status popup should close after page has finished loading. And actually no error 
should happen.

Reproducibility: 
100%

Build Date & Platform Bug Found: 
Win32, 2000071120

Additional Builds and Platforms Tested On: 

Additional Information: 
There are more JS bugs in mozilla going to be uncovered by this tripod 
filemanager...you'll see as soon you try to perform any action. I'll file those 
too later.

Comment 1

18 years ago
This is exactly the error I mentioned in bug 45364 in 2000071221 Linux 2.2.16
Slackware 7.1
(Reporter)

Comment 2

18 years ago
Actually the exception happens 5 times in a row (seen in the JS console or if 
you watch the mozilla console during the load).
(Reporter)

Comment 3

18 years ago
Matthew, you should give it a better summary I guess, its a bit too generic. 
Though this could be a dupe then.

Someone who sees behind the things please verify?

Comment 4

18 years ago
Entry at index 1 is sabotaged.cjb.net
WEBSHELL+ = 5
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 6
WEBSHELL+ = 7
Setting content window
*** Pulling out the charset
in SetSecurityButton
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document: Done (29.217 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document http://www.sabotaged.cjb.net/ loaded successfully
Document: Done (7.733 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document http://hammer.prohosting.com/banner.html loaded successfully
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]


is what i get when visiting my site at http://sabotaged.cjb.net

as a lot of other sites using javascript like home.excite.com (@home's page)

Comment 5

18 years ago
Using  Mozilla tip builds 2000-07-12 1PM PDT on WinNT, Linux.
Confirming the hanging popup on WinNT, but not on Linux.

On Linux, the popup goes way by itself - I had no problems with it.

On WinNT, the popup does not go away when I first load the page; I have to 
dismiss it manually. However, if I RELOAD the page, the popup DOES go away 
by itself! If I reload the page again, it appears and goes away by itself TWICE! 

This seems either like bad HTML or a browser problem; not JS Engine.
Reassigning to Browser-General for triage. Here are printouts from my WinNT 
console. On first load, when the popup was hanging, the line appearing in the 
console at the time was "Opening file 63434735.s failed".

On the reload, when the popup went away by itself, I did not get this error. 
The error noticed by the reporter, "...Component does not have requested 
interface... etc. etc." occurred both on first load and on reload, and 
therefore may not be the actual cause of the problem ... (?)

FIRST LOAD (popup did not go away by itself):
      etc. 
       .
       .
Enabling Quirk StyleSheet
Document: Done (1.938 secs)
*** check number of frames in content area
Document http://www.tripod.de/hpstudio/fmframeset/loading_popup.html loaded 
successfully
Enabling Quirk StyleSheet
WARNING: not calling OnDataAvailable, file 
d:\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 404
WARNING: not calling OnDataAvailable, file 
d:\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 404
nsLineLayout: nsGfxControlFrame2@0384266C didn't set max-element-size!
*** check number of frames in content area
*** check number of frames in content area
*** check number of frames in content area
Document: Done (9.078 secs)
*** check number of frames in content area
Document http://www.tripod.de/hpstudio/fmframeset/index.jsp loaded successfully
nsLineLayout: nsGfxControlFrame2@0384266C didn't set max-element-size!
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Document: Done (1.968 secs)
Opening file 63434735.s failed
JavaScript error:
 line 0: uncaught exception: [Exception... "Component does not have requested 
interface"  code: "-2147467262" nsresult: "0x800
04002 (NS_NOINTERFACE)"  location: "<unknown>"]
WEBSHELL- = 9
WEBSHELL- = 8




RELOAD (popup went away by itself):
    .
    .
Enabling Quirk StyleSheet
Document: Done (1.578 secs)
*** check number of frames in content area
Document http://www.tripod.de/hpstudio/fmframeset/loading_popup.html loaded 
successfully
Enabling Quirk StyleSheet
*** check number of frames in content area
*** check number of frames in content area
*** check number of frames in content area
Document: Done (10.657 secs)
*** check number of frames in content area
Document http://www.tripod.de/bin/membership/len_login loaded successfully
Enabling Quirk StyleSheet
Enabling Quirk StyleSheet
Document: Done (0.906 secs)
*** check number of frames in content area
JavaScript error:
 line 0: uncaught exception: [Exception... "Component does not have requested 
interface"  code: "-2147467262" nsresult: "0x800
04002 (NS_NOINTERFACE)"  location: "<unknown>"]
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 6

18 years ago
I should also note that on WinNT, for some reason it is not asking me 
for my user name and password "moztest/billyboy") on first load. 

On all subsequent reloads, I WAS asked for these ...

Comment 7

18 years ago
->DOM
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale

Comment 8

18 years ago
Hrm strange, on 2000071221 on Slack71 I got the following output when visiting
the page, i entered my username/password and it redirected me to another page
and asked me for my login/password again and then it let me in, a popup did open
up for 5 seconds and then closed itself, but with the following debugging
output:

*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document: Done (2.321 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document http://www.tripod.de/hpstudio/fmframeset/loading_popup.html loaded
successfully
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document: Done (8.638 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties
Document http://www.tripod.de/hpstudio/fmframeset/index.jsp loaded successfully
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component does not have requested
interface"  code: "-2147467262" nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "<unknown>"]

Document: Done (2.291 secs)
*** check number of frames in content area 
Error getting url widget service: TypeError: Components.classes[progid] has no
properties


enjoy :) oh, might I add that maybe it's a good thing not to have popups or have
a popup limit ;)

Comment 9

18 years ago
shouldn´t bug 45364 marked as a duplicate ? and OS should changed to all (cause 
it also happens on linux)
(Assignee)

Comment 10

18 years ago
The error about Components.classes[progid] is most likely unrelated to the
problem described in this bug, please confirm the problem with a fresh build
and open a new bug on that.

As for the NS_NOINTERFACE error (which is also unrelated to the problem with
the popup not going away) that is coverd by bug 45357 (which has a fix).

Since the popup window does go away now and all other problems are, or should
be, in other bugs I'm marking this as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

18 years ago
Tried to verify with 071320 on Win2k; the popup still is not closing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: JS error: uncaught exception with location → JS problem: popup window will not close (window.close()?)

Comment 12

18 years ago
Using  Mozilla tip builds 2000-07-14 1PM PDT on WinNT, Linux.
Confirming the hanging popup on WinNT, but not on Linux.

On Linux, the popup goes way by itself - I had no problems with it.

On WinNT, the popup does not go away when I first load the page; I have to 
dismiss it manually. However, if I RELOAD the page, the popup does go away 
by itself! If I reload the page again, it appears & goes away by itself TWICE. 

Comment 13

18 years ago
If this is of any help -

If you go to this site with any browser (NN4.X, IE4, or Moz), and click 
the Back button on the browser to return to whatever site you were at
originally, the popup will appear and hang.
(Assignee)

Comment 14

18 years ago
It looks like this is due to the incorrect onload event fireing order since it
sometimes works on some computers, and sometimes doesn't work..., i.e. it's a
timing related problem.

Marking this as a dup of 30627 (nsbeta2+) for now, please undup if the "popup
window doesn't go away" problem isn't fixed once 30627 is fixed.

*** This bug has been marked as a duplicate of 30627 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 15

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.