Closed Bug 453716 Opened 14 years ago Closed 14 years ago

colorful icon tab strip in Page Info and Add-ons doesn't indicate keyboard focus

Categories

(Firefox :: Keyboard Navigation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 334370

People

(Reporter: info, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080904035000 Minefield/3.1b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080904035000 Minefield/3.1b1pre

You can move the keyboard focus to the colorful icon tab strip in Tools > Page Info and in Tools > Add-ons, but there's no indication when it's in there.

This is especially important while bug 453714 remains open: the only way to switch tabs from the keyboard is to set the focus to the tab strip then use the arrow keys.

The old plain tabbed dialog for Tools > Page Info in Firefox 2.0.0.7 showed a dotted line in the tab that has the keyboard focus/

Reproducible: Always

Steps to Reproduce:
1. Choose Tools > Page Info or Tools > Add-ons
2. Press tab repeatedly
Actual Results:  
As the keyboard focus moves through each item in the dialog, each highlights in some way.  Until the focus enters the icon tab strip, where there's no highlight.

Expected Results:  
Some visual indication of keyboard focus.

Maybe this and bug 453714 are bugs with some XUL component; I don't know the technical term for "colorful icon tab strip".
See bug 334370 - the technical term is "XUL radiogroup pretending to be a tabbox" whether it's within the prefwindow binding or copied into the window's own XUL as it is for the imitators, and the problem with showing focus is that the powers that be will want that focus indicator to work like a tabbox, showing an outline if you move focus there with the keyboard, or if you click on something that's already focused from a previous click, but not on the initial click.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334370
You need to log in before you can comment on or make changes to this bug.