Mail message body truncated *after* receipt/download from IMAP

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: gershman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080708)

I'm running Thunderbird 2.0.0.16 on XPsp2 (though this problem as occurred on other versions).  I connect to an IMAP server to read email.  Virtually all email seems to download fine when viewing.  However, one message in particular coming from my own server gets truncated when I view the email.  It is a short 'reminder' message.  Only 5 characters of the 20 character message show in the message viewing windows.  

HOWEVER, the 'pop up notifier" box that shows up above the task tray telling me of the new message correctly displays the entire message body (since it's short enough).  Thus I'm assuming the message was downloaded from IMAP correctly at some point.  Only when viewing in the message window is it truncated.

Saving the email source saves only the truncated version.

Reproducible: Always

Steps to Reproduce:
1.(unknown...it happens all the time with this particular message only.  No real steps to take...automatic email checking is used.)
2.
3.
Actual Results:  
Truncated message

Expected Results:  
Full 20 character message

Comment 1

10 years ago
Could you attach the message, please, so that others can try to reproduce the problem and identify the bug?
(Reporter)

Comment 2

10 years ago
Created attachment 337575 [details]
Email message saved (though truncated)

As requested, uploaded message as attachment.  However, I modified the contents to remove details of domain name and IP addresses of company...nothing more.

Hope this helps.

Comment 3

10 years ago
Do you control the script that produces this message?  If so, or if you can get a copy of it, could you try changing the message and seeing what happens?

In particular, I think it would be helpful to know what happens if the overall message is a few characters shorter, a few characters longer, or significantly longer.  Does it still always get cut off at the same place, or does it move around?
(Reporter)

Comment 4

10 years ago
I didn't need to perform additional steps.  The full message started coming in after Thunderbird upgraded...  So this bug can be closed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 5

10 years ago
Fixed -> Worksforme.  The former is only for bugs with patches.  Glad it's working!
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.