compatibility: text invisible in some frames that worked with FireFox 2.x

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: avi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

text in top frame on site ("User Results") is invisible unless I use IE Tab add-on to switch rendering engine to Internet Explorer. In older FireFox 2.x this was not necessary. 

Reproducible: Always

Steps to Reproduce:
1.install and run tcpIQ line speed meter - let it collect some data or manually force it to do a few tests so you will have data to display
2.from line speed meter menu choose "My results..."
3.observe empty frame in "User Results" frame
4.use IE Tab plug-in to switch rendering engine to internet explorer - text appears
Actual Results:  
text reappears only with IE rendering engine

Expected Results:  
text should have appeared properly even with the FireFox rendering engine

compare with performance in old FireFox 2.x. 
Compatibility with websites only designed with IE in mind is still a FireFox bugaboo

Comment 1

10 years ago
"Compatibility with websites only designed with IE7 and below in mind is still a FireFox, Opera, Safari, Konqueror, Hv3, Chrome and IE8 bugaboo"
There, fixed that for ya ;)
The text is not invisible, the text color is only the same as the background.
Try to mark the text and you will see it.

You or someone else needs to find the reason for that (for example with firebug) and then we can decide if this is valid or not.
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> "Compatibility with websites only designed with IE7 and below in mind is still
> a FireFox, Opera, Safari, Konqueror, Hv3, Chrome and IE8 bugaboo"
> There, fixed that for ya ;)
Mardeg, thanks for fixing it .... that's the kind of fix I usually expect to see from a micro$oft engineer.....
(Reporter)

Comment 4

10 years ago
(In reply to comment #2)
> The text is not invisible, the text color is only the same as the background.
> Try to mark the text and you will see it.

You are correct!
what's interesting is that this didn't happen with Firefox 2.x, so there's some small something that's slightly less compatible than before, that's all..
> 
> You or someone else needs to find the reason for that (for example with
> firebug) and then we can decide if this is valid or not.

Validity is in the eye of the beholder - is it the website programmer's fault, or should Firefox development have more of an eye to copping to IE's way of rendering web pages?  Unfortunately, I haven't the skills to do the analysis

For the meanwhile, IE Tab to the rescue...

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.