Checking mCopyState and copySucceeded in nsMsgLocalMailFolder::EndCopy is not needed because these values is checked at the beginning of the function.

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Backend
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

Trunk
Thunderbird 3.3a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15) Gecko/20080702 Ubuntu/8.04 (hardy) Firefox/2.0.0.15 Kazehakase/0.5.4
Build Identifier: 

Checking mCopyState and copySucceeded in nsMsgLocalMailFolder::EndCopy is not needed because these values are checked at the beginning of the function.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

10 years ago
Created attachment 336977 [details] [diff] [review]
Proposed patch

The patch also changes the function argument name. 
 copySucceeded -> aCopySucceeded
Attachment #336977 - Flags: superreview?(bienvenu)
Attachment #336977 - Flags: review?(bienvenu)
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Assignee: nobody → poincare
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Version: unspecified → Trunk

Comment 2

7 years ago
Created attachment 483970 [details] [diff] [review]
de-bitrotted patch

thx for the patch, I de-bitrotted it and it seems fine.
Attachment #336977 - Attachment is obsolete: true
Attachment #483970 - Flags: review+
Attachment #336977 - Flags: superreview?(bienvenu)
Attachment #336977 - Flags: review?(bienvenu)

Updated

7 years ago
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/e6c88bcb6d6c
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
You need to log in before you can comment on or make changes to this bug.