Bookmarks should be merged when importing and not duplicated

RESOLVED DUPLICATE of bug 271437

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 271437
10 years ago
10 years ago

People

(Reporter: Jay Freeman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

There should be a mechanism to prevent already existing bookmarks from being added to prevent duplicates while importing.

The same mechanism should take into account duplicated tags per bookmark.

It's no fun having half a dozen "Recently Bookmarked" and "Recent Tags" and such alike.


Reproducible: Always

Steps to Reproduce:
1. Choose "Organize Bookmarks" from the Bookmarks menu.
2. Choose "Import and Backup"
3. Pick up your HTML file.
Actual Results:  
Duplicated bookmarks are added without taking into account they are already there.

Expected Results:  
The import mechanism should be wise enough to filter out the duplicates. As it's now the Library is filled out with garbage making it unmanageable.

The bookmark menu is also filled with redundant bookmarks and shortcuts duplicating functionality harming usability and productivity.
If you use the .json file to restore it will overwrite all your bookmarks.
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> If you use the .json file to restore it will overwrite all your bookmarks.

I'm not talking about the "Restore" function. I'm talking about "Import" from HTML file.

I don't understand your comment.
The function of importing bookmarks.html is not replacing bookmarks but only adding bookmarks. If you import them 3 times you'll have 3 times the same bookmarks. That's how it is designed. 
This bug must be a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 271437
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> The function of importing bookmarks.html is not replacing bookmarks but only
> adding bookmarks. 

Then you should rename that feature "Add Bookmarks from external file" or something and not "Import".

If you import them 3 times you'll have 3 times the same
> bookmarks. That's how it is designed. 

Then it's badly designed! What's the benefit of having the duplicates? Can you explain that?

> This bug must be a duplicate.

Another bookmark bug that goes unresolved. It's frustrating that the user cannot consolidate their bookmarks without losing data or adding garbage. Software should work for the user, not the other way around.
You need to log in before you can comment on or make changes to this bug.