If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Autocomplete with maxlength

VERIFIED DUPLICATE of bug 444728

Status

()

Firefox
Address Bar
--
major
VERIFIED DUPLICATE of bug 444728
9 years ago
9 years ago

People

(Reporter: geetar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.52 (Windows NT 5.1; U; pl)
Build Identifier: 3.0.1

Let's create a textbox and enter a text there with length of e.g. 255 chars.
Firefox remembers this form data.
Let's then set the maxlength of the textbox to e.g. 125 chars.
Using autocomplete functionality I am still able to enter those 255 chars into textbox, which is wrong.

Reproducible: Always

Steps to Reproduce:
1. Steps are in the details section, just create a html page for yourself.
2.
3.
Actual Results:  
In my application too long text was submitted to DB and query crashed.

Expected Results:  
Do not let me enter too long text.

Comment 1

9 years ago
> In my application too long text was submitted to DB and query crashed.

You need to do server-side checks too, so malicious users (who might use modified web browsers) can't screw up your database...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444728
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.