Closed Bug 453819 Opened 14 years ago Closed 14 years ago

Performance regression in firefox 3

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 372039

People

(Reporter: heythem.jmour, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When we have in a html page a large background image (example 1280x1024 image) and we resize it to fit to a small display (640x480) the display of the html page becomes very slow.
The same test with Firefox 2 doesn't show any performance problems.
Workaround: resize natively the background image.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Such a general description isn't enough.
Either attach a testcase or point to a URL.

I assume that you mean a fixed background and you mean bug 372039
(easy to find with search keywords "background slow"

marking as dupe, please reopen if you don't mean a fixed background.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372039
The html file contains an 1024x768 image "langue.png" (img tag).
When we load this html file on the test machine, the display becomes very slow (CPU usage ~100%). Here are the characteristics of the test machine :
  - Windows XP SP2.
  - Intel P4 2GHz
  - 512Mb RAM
  - 640x480 display
Now we change the image to langue2.png (which is the same image natively resized to 640x480) performance is correct.
I am not sure that this is the same problem with bug id 337420...
Here the image is not placed with background-image css property.
You need to log in before you can comment on or make changes to this bug.