Unifinder should allow multisort (second sort criteria is the one from the previous sort)

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
enhancement
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Mozilla 1.8 Branch

Details

Unifinder should allow multisort (second sort criteria is the one from the previous sort), i.e.

1. Sort by start date.
2. Sort by calendar.

Expected result:
Events are sorted by calendar name and the ones from the same calendar by start date.

Comment 1

10 years ago
This is a regression from 0.3 (and 0.6a1, which are both on 1.9) because Array.sort in 1.8 uses an unstable sort algorithm (QuickSort) and in 1.9 uses a stable sort algorithm (MergeSort, bug 224128).  It should be fixed automatically by the upgrade back to the 1.9 platform.

Comment 2

9 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 Calendar/1.0pre (BuildID: 20081020094120)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.