<TEXTAREA> Back/Forward Arrow keys jump 2 chars instead of 1

VERIFIED FIXED in Future

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Nikhil Bhatla (gone), Assigned: saari (gone))

Tracking

({regression})

Trunk
Future
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][nsbeta3-])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Windows 98 Build 2000071112

For some strange reason, the keyboard forward/back arrow buttons jump 2 
characters forward/back instead of just 1.  I first noticed this bug in a 
<TEXTAREA> at bugzilla.  Regular text fields do not experience this bug.
(Reporter)

Comment 1

18 years ago
keyword nsbeta2 because if goes on unfixed, it makes simple keyboard text 
navigation in a form's <textarea> simply unusable.
Keywords: nsbeta2

Comment 2

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]

Comment 3

18 years ago
reassigning to beppe
Assignee: clayton → beppe

Comment 4

18 years ago
I don't see a problem in this textarea when using the left and right arrow keys
on a Macintosh debug build from today.  Is this Windows only?

I do see a problem where up and down arrows in single-line inputs or textareas
aren't working properly on Macintosh (possibly related?).

Akkana--do you want to take this bug or should I?
Keywords: regression
Target Milestone: --- → M17

Comment 5

18 years ago
assigning to brade
Assignee: beppe → brade

Comment 6

18 years ago
I'm seeing this problem in my Win32 build from today. I don't see it in the URL
bar, but I see it in the textfields and textareas in a bugzilla bug like this one.

Comment 7

18 years ago
I just tried again and now I see it on Mac (same build, same web site (bugzilla))!

Comment 8

18 years ago
I can't reproduce this on Linux, in text fields or textareas of a bugzilla page
(nor in the urlbar).  Last Thursday, saari and I were seeing various strange
behavior with the order of XUL and XBL key bindings, and this may be another
instance of that strange behavior.  Can someone find a way to reproduce this
consistently?

Comment 9

18 years ago
Created attachment 11500 [details] [diff] [review]
partial fix/patch to nsXBLEventHandler.cpp

Updated

18 years ago
OS: Windows 98 → All
Hardware: PC → All
Whiteboard: [nsbeta2+] → [nsbeta2+] expected fix by 7/21/2000

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 10

18 years ago
fix checked in for 7/20/2000 builds
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
Alas, this morning, on Linux, I'm seeing this problem in spades: sporadically,
all XBL events (both platform, like ^H, and XP, like arrow keys) will be handled
twice in text fields and text areas.  Didn't happen yesterday.  I can't see how
Kathy's change could have caused this.  I'm still trying to figure out a way to
reproduce this reliably, but it happens frequently when I use the product to
type stuff into bugzilla windows, and once it starts happening, it keeps
happening everywhere on that page until I reload the page.  (So probably, the
event system is getting confused somewhere along the line.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

18 years ago
Odd. I can't NOT make it happen. Goes on all the time.
RH6.2 w/upgrades: kernel 2.2.16, gtk+ 1.2.8, Gnome-core 1.2.1, sawfish 0.30

Comment 13

18 years ago
Removing eta date since the fix I checked in doesn't seem to be sufficient.
I have no clue what is going on here.  cc hyatt
Shorten summary to fit.
Summary: <TEXTAREA> Back/Forward Arrow keyboard buttons jump 2 characters instead of just one → <TEXTAREA> Back/Forward Arrow keys jump 2 chars instead of 1
Whiteboard: [nsbeta2+] expected fix by 7/21/2000 → [nsbeta2+]
(Assignee)

Comment 14

18 years ago
Okay, I'm on this. 
Are we still having the problem on all platforms?

Comment 15

18 years ago
It was sporadic yesterday.  Unfortunately yesterday's and this morning's builds
weren't good enough to use regularly, to try to find a regularity as to how
often it happened.  I haven't seen it yet today, but I haven't used the build
much yet.  R.K.Aa -- are you still seeing this all the time?
(Reporter)

Comment 16

18 years ago
I am no longer seeing this bug on a self-build I did on my Mac (OS 9.0) yesterday 
morning.

Comment 17

18 years ago
still see this in build ID 2000-072113 linux.
Arrow back/forth and arrow up/down all do the double stunt.

Comment 18

18 years ago
This was to have been assigned to saari but apparently that didn't happen.  He
was investigating this yesterday.
Assignee: brade → saari
Status: REOPENED → NEW

Comment 19

18 years ago
I'm still seeing it, but only sporadically.  I just saw it on yesterday's build,
on a bugzilla page I had just loaded.  I think what I did was use the mousewheel
to scroll down a little, click in a text field that already had something in it,
hit ^H (Unix platform binding for delete-previous-char), and two characters were
deleted.  I'm fairly sure I had not done anything else involving XBL or XUL key
bindings since loading the page, just scrolling and reading.

Comment 20

18 years ago
Please resolve the duplication and assignment between this bug and Bug 42332. 
They look like dupes, and they are both M17.

Comment 21

18 years ago
*** Bug 42332 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

18 years ago
I'm still not able to reproduce this. I'm switching over to linux as my dogfood
machine to see if I can catch this happening.
Whiteboard: [nsbeta2+] → [nsbeta2+

Comment 23

18 years ago
Per todays triage, moving to nsbeta2-.  Hard to reproduce.
Whiteboard: [nsbeta2+ → [nsbeta2-]
(Assignee)

Updated

18 years ago
Keywords: nsbeta3
(Assignee)

Comment 24

18 years ago
nominating nsbeta3, but I still havn't seen  this

Comment 25

18 years ago
nsbeta3-, won't hold for bugs we can't reproduce.  renominate if you get a
reproducible case.
Whiteboard: [nsbeta2-] → [nsbeta2-][nsbeta3-]
Target Milestone: M17 → Future

Comment 26

18 years ago
I keep getting this all the time on 2000073009 on linux, on all 4 arrow keys,
and in both text areas and input lines. My system:
Mandrake 7.1, kernel 2.2.16, glib/gtk+ 1.2.7, gnome-core 1.1.9, and running
mozilla in kde 1.1.2
It would be a shame if this bug stayed in the betas because of reproduction
problems.....

Comment 27

18 years ago
now i'm only getting this on some pages, including this one.... wierd....
(Assignee)

Comment 28

18 years ago
I've been trying to repro this on my redhat 6.2 system without success. 
I guess the next step is to construct a clone of the madrake system and hope that 
does it! 
Status: NEW → ASSIGNED

Comment 29

18 years ago
*** Bug 47131 has been marked as a duplicate of this bug. ***

Comment 30

18 years ago
Sorry that I posted it as new bug. I have the same problem in all directions on
THIS page, Build 080104 Windows 98.

Comment 31

18 years ago
I am now getting the same behaviour when writing a new message on Linux M18
2000080108. This DID NOT happend in 2000073009.

Comment 32

18 years ago
*** Bug 47270 has been marked as a duplicate of this bug. ***

Comment 33

18 years ago
I get this on NT4.0sp6, Mozilla 2000080820. In fact, I'm seeing it right now!

Comment 34

18 years ago
This WFM right now on 2000082421, but i'll have too see if it doesn't reappear
later...

Comment 35

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca
(Assignee)

Comment 36

18 years ago
This should be works for me now, unless somone out there is still seeing it.

Comment 37

18 years ago
Resolving as fixed, as no new reports have been recieved in over two months, and
it seems to be working. Reopen if you are still getting this with a current build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 38

18 years ago
VERIFIED.  Sound reasoning to me.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.