TM: investigate Chronoscope

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
P2
enhancement
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: dvander, Assigned: jimb)

Tracking

unspecified
mozilla1.9.1
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

URL from Brendan: http://api.timepedia.org/benchmark/

Investigate TraceMonkey's performance here.

Updated

10 years ago
Severity: normal → enhancement
Priority: -- → P2
Target Milestone: --- → mozilla1.9.1
blocking1.9.1+.  Assigning to jim blandy.
Assignee: general → jim
Flags: blocking1.9.1+
(Assignee)

Comment 2

10 years ago
Hah.  With the JIT enabled, the graph doesn't display at all.  (tm and mc).

Comment 3

10 years ago
Jim, could you try to debug this?
(Assignee)

Comment 4

10 years ago
This seems to be fixed in today's TM.  I was able to run the benchmark with the JIT both disabled and enabled; the difference between the mean pass runtimes was minimal.  I'll look into where this benchmark spends its time.

Comment 5

10 years ago
WFM confirmed. I suggest to file an enh / non-blocker on perf (test is getting slower with each run in my debug build). I will WFM close this.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Perf bug is bug 480801.

/be
You need to log in before you can comment on or make changes to this bug.