All users were logged out of Bugzilla on October 13th, 2018

History won't sync due to NS_ERROR_FILE_IS_LOCKED

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: basilevs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; ru; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: 

History won't sync because for each change applied a error appears.
2008-09-05 23:46:30	Service.HistStore	TRACE	Processing command: {"action":"create","GUID":"1220593394055535:http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=6594","depth":0,"parents":[],"data":{"URI":"http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=6594","parentGUID":"","time":1220593394055535,"title":"Keyboard shortcuts - Help Center","transition":1}}
2008-09-05 23:46:30	Service.HistStore	DEBUG	  -> creating history entry: 1220593394055535:http://mail.google.com/support/bin/answer.py?hl=en&ctx=mail&answer=6594
2008-09-05 23:46:31	Service.HistStore	ERROR	Exception caught: Component returned failure code: 0x8052000e (NS_ERROR_FILE_IS_LOCKED) [nsINavHistoryService.addVisit]
2008-09-05 23:46:31	Service.HistStore	TRACE	Processing command: {"action":"create","GUID":"1220593375894912:http://mail.google.com/mail/#settings","depth":0,"parents":[],"data":{"URI":"http://mail.google.com/mail/#settings","parentGUID":"","time":1220593375894912,"title":"Gmail - Settings - basilevs@gmail.com","transition":1}}
2008-09-05 23:46:31	Service.HistStore	DEBUG	  -> creating history entry: 1220593375894912:http://mail.google.com/mail/#settings
2008-09-05 23:46:31	Service.HistStore	ERROR	Exception caught: Component returned failure code: 0x8052000e (NS_ERROR_FILE_IS_LOCKED) [nsINavHistoryService.addVisit]


Reproducible: Always

Steps to Reproduce:
1.Do some browsing on the remote synced computer.
2.Try to sync on another one, keeping a history pane open.

Actual Results:  
No history changes is seen.
The error mentioned appears in Weave logs.

Expected Results:  
Browsing history should be extended to include urls that were visited on the remote computer.

The same seems to happening on Linux.
(Reporter)

Comment 1

10 years ago
This might be duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=442300

Comment 2

10 years ago
This is no longer an issue, we get the same database connection from the history service.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.