Closed Bug 45394 Opened 24 years ago Closed 24 years ago

can't launch app after clicking "empty disk cache" in prefs

Categories

(Core :: Networking: Cache, defect, P3)

PowerPC
All
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: Brade, Assigned: bugs)

References

Details

(Keywords: crash, Whiteboard: [nsbeta2+] ETA 7/25)

I had the misfortune of having (essentially) the whole application delete from
under me while I was running today.

(running Mac debug build from this morning)

Steps to reproduce:
 * open preferences
 * select Advanced -> Cache
 * click the button labeled "Clear Disk Cache"
 * switch to the Finder
 * notice that the following folders were deleted (next to the application):
     Chrome
     Components
     Essential Files
     Plugins
     Search Plugins
Nominating for nsbeta2. This is a very serious problem.
Keywords: nsbeta2
Status: NEW → ASSIGNED
Target Milestone: --- → M17
note: this will cause a crash when the prefs dialog is dismissed (or shortly 
thereafter) since all of the shared libraries have been deleted.
Keywords: crash
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
->gordon
Assignee: neeti → gordon
Status: ASSIGNED → NEW
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA 07/19
Gordon,

Bug 45658 and 45656 may be related to this bug.

Neeti
Per gordon's excellent investigation and his email this seems like a bug then 
ben should own--

(quote)
The cache pref panel contains a textfield that contains the 
browser.cache.directory preference.  That preference is stored as an
nsIFileSpec, which on Linux and Windows equates to a string, but on Mac it is 
actually an alias data structure.  The TextField
prefType attribute in pref-cache.xul, however, specifies the preference as 
"string": 

          <textfield id="browserCacheDirectory" flex="1" pref="true" 
preftype="nsIFileSpec" 
                     prefstring="browser.cache.directory" 
prefattribute="value"/> 
  

This causes the it to display as garbage on the Mac ( Bugzilla bug 45658 ), and 
if the user tries to edit the field can lead to  Bugzilla
bug 45656  and  Bugzilla bug 45394 (which can cause the installed application to 
self-destruct).  Only the last is actually nsbeta2+,
and I plan to add additional sanity checking to the clear disk cache code, but I 
think the pref panel should be fixed and I'm not sure
the best way to go about it. 
(unquote)

So assigning to ben. And clearing the ETA 
Assignee: gordon → ben
Whiteboard: [nsbeta2+] ETA 07/19 → [nsbeta2+] ETA ???
Per bug mtg, setting ETA to 7/25
Whiteboard: [nsbeta2+] ETA ??? → [nsbeta2+] ETA 7/25
Ben and I talked, and we think allowing users to set their own cache directories 
may be a dubious feature in the first place.  The textfield in 4.x isn't directly 
editable, as it now is in mozilla.  We need to remove this feature, modify it, or 
put in seatbelts and airbags to minimize the damage when the user accidently 
specifies the wrong directory.
I would like the ability to specify my cache directory, especially if the
default location would put it
in an area that is "challenged" for space.

What do we need to do to fix the problem on the mac side so this preference
could be re-enabled?
One many problem could/will be this:
I have my profile data on a share NT drive, but I definatly dont want the cache 
on that drive, since the access is *much* slower than to the local disk.
I always have my profile on a shared drive but the cache on the local disk. With 
the removal of the Select Cache Folder this is no longer possible.
This feature has been removed for nsbeta2 because it would have taken me a day 
to code up a 'safe' implementation, a day which I don't have to spend on working 
on features I don't personally use ;) We can revisit this for nsbeta3 if there 
is time. Someone file a bug on implementing the feature. 
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
Bug 46490 filed
verified as fixed (mac debug build from this morning)
Status: RESOLVED → VERIFIED
*** Bug 45658 has been marked as a duplicate of this bug. ***
*** Bug 45658 has been marked as a duplicate of this bug. ***
Blocks: 45656
OS: All
You need to log in before you can comment on or make changes to this bug.