Browser requirements for Bugzilla searchplugin

RESOLVED WONTFIX

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: Cédric Corazza, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
The home page mentions that Firefox 2 or Internet Explorer 7 are needed to install the Bugzilla searchplugin.
I made tests with Firefox 3.1a2 and it also works. I couldn't make tests for Internet Explorer 8 beta.
I think the home page should mention something like:
"Firefox 2 and higher or Internet Explorer 7 and higher" (if it also works with IE 8 beta).

Comment 1

10 years ago
Created attachment 337200 [details] [diff] [review]
patch v.1

I think we should mention that this uses the OpenSearch description format.
Assignee: general → shimono
Status: NEW → ASSIGNED
Attachment #337200 - Flags: review?

Comment 2

10 years ago
Comment on attachment 337200 [details] [diff] [review]
patch v.1

>-      the Quick Search plugin</a> (requires Firefox 2 or Internet Explorer 7)
>+      the Quick Search plugin</a> (requires a browser that supports OpenSearch description format like Firefox 2 or Internet Explorer 7)

That's not the right place to be too technical, IMO. When you say that such or such program requires kernel 2.2.x with 256 Mb of RAM, this also implies "or better" to me. Does it worth the fix?
Attachment #337200 - Flags: review? → review-
The point of the phrase is not "requires OpenSearch support" but rather "requires support for adding OpenSearch plugins through window.external.AddSearchProvider()". Obviously, you aren't going to say that in the page, since the user isn't going to know whether or not their browser does, which ought to then make you think "oh, but their browser knows" and so you only want to show the link at all |if (window.external && ("AddSearchProvider" in window.external))|

Comment 4

10 years ago
(In reply to comment #2)
> That's not the right place to be too technical, 

I didn't think 'supports OpenSearch' is too technical..
Of cource, currently other browsers, such as Opera, Safari, etc., don't support this. But shuold we add all browsers when they impliment that?
# can use OpenSearch xml with editing .ini directly at Opera?

Comment 5

10 years ago
Note that browsers like Camino also support the OpenSearch functionality.

Updated

10 years ago
Duplicate of this bug: 448385
(In reply to comment #3)
> you only want to show the link at all |if (window.external &&
> ("AddSearchProvider" in window.external))|

I think this should be taken into account when fixing this bug in addition to rephrasing the requirements text to be more generic.

Himorin, please assign this back to you if you still plan to work on this bug.
Assignee: shimono → ui
Severity: minor → trivial
Status: ASSIGNED → NEW
Component: Bugzilla-General → User Interface
Whiteboard: [Good Intro Bug]

Comment 8

6 years ago
The Search plugin is now only displayed if the browser supports it, see bug 475063. So if you see it, you can use it. No need to explain anything to the user anymore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [Good Intro Bug]
You need to log in before you can comment on or make changes to this bug.