Closed Bug 454010 Opened 14 years ago Closed 13 years ago

Replace Address book and Mailnews Quick Search textboxes with new search versions ("Warning: Timed texboxes are deprecated.")

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Nomis101, Unassigned)

References

()

Details

(Whiteboard: [address book fixed])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_4; de-de) AppleWebKit/528.1 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1b1pre) Gecko/20080906035155 Shredder/3.0b1pre

If I open my addressbook I get the following warning in my Error Console:

<< Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/addressbook/addressbook.xul >>


Reproducible: Always

Steps to Reproduce:
1. Open addressbook
2. Open Error console
3.
No real need for separate bugs on the addressbook and the exact same error you get opening the 3pane window: they're both because bug 450733 got tired of type="timed" while we're still inheriting from it in http://mxr.mozilla.org/comm-central/source/mail/base/content/search.xml#52
Blocks: 450733
Status: UNCONFIRMED → NEW
Component: Address Book → Mail Window Front End
Ever confirmed: true
OS: Mac OS X → All
QA Contact: address-book → front-end
Hardware: Macintosh → All
Summary: Warning: Timed texboxes are deprecated. (addressbook.xul) → "Warning: Timed texboxes are deprecated." loading addressbook or 3pane windows
Version: unspecified → Trunk
I think you should be able to inherit from type="search" instead, get rid of the custom clear button and hide the default search icon with css. You should also use emptytext for the searchCriteria stuff, although that could be done in a separate bug.
Even though bug 450733 caused this, I don't think it makes sense to add a direct dependency. The warning isn't a regression but intentional information from that bug's perspective.
Blocks: 451852
No longer blocks: 450733
Depends on: 451854
Summary: "Warning: Timed texboxes are deprecated." loading addressbook or 3pane windows → Replace Address book and Mailnews Quick Search textboxes with new search versions ("Warning: Timed texboxes are deprecated.")
Duplicate of this bug: 451853
No longer depends on: 451854
Duplicate of this bug: 451854
I also get exactly the same Warning for: 
chrome://messenger/content/messageWindow.xul

I was trying to fix this for myself, but I'm not skilled enough in code juggling.
Duplicate of this bug: 459162
Duplicate of this bug: 461468
I still get this warning in the current build. So it seems you also will get this in the forthcoming Beta1 release.
When will this be fixed, in Beta2?
Maybe this is not a "real" bug, but it will confuse the (normal) user.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1b3pre) Gecko/20081126 Thunderbird/3.0b1pre
(In reply to comment #10)
> Maybe this is not a "real" bug, but it will confuse the (normal) user.

Most normal users probably won't even look at the error console as they don't know what it is. For those users with a bit of a thought they will probably work it out pretty quick.
Flags: wanted-thunderbird3+
Keywords: helpwanted
These 2 occurrences are the last users of this feature.
Bug 474711 attachment 399144 [details] [diff] [review] just fixed the address book search boxes. I believe the quick search textbox will be fixed by the main patch to go on that bug as well.
Depends on: 474711
Whiteboard: [address book fixed]
This is fixed, isn't it?
Yup.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
confirm. It is fixed in

Mozilla/5.0 (X11; U; Linux i686 (x86_64); de; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4
You need to log in before you can comment on or make changes to this bug.