Closed Bug 454118 Opened 12 years ago Closed 12 years ago

Bookmark toolbar is not expanded during Firefox startup

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 447571

People

(Reporter: adwoz, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2) Gecko/20080829082037 Shiretoko/3.1a2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2) Gecko/20080829082037 Shiretoko/3.1a2

When Firefox is started, the bookmark toolbar stays collapsed and >> appears in the toolbar, and the google search form fills the full width of the toolbar. 

Reproducible: Always

Steps to Reproduce:
1. customize the bookmark toolbar to contain the search form, right justified
2. add a few folders to the bookmark toolbar, to the left of the search form
3. save customization and close FF
4. open FF and '>>' appears in the bookmark toolbar, google search form fills full width.
Actual Results:  
'>>' appears in the bookmark toolbar

Expected Results:  
'>>' should be expanded to show all top level bookmarks and folders
This problem does not exist in FF 3.0.x - bookmark toolbar expands as expected during startup.
In addition to the above.

1-4 as same as the above.
5. View > Toolbars > Customize...
6. Close "Customie Toolbar window"

The bookmarks toolbar is expanded again.
It seems to regression of  Bug 443734
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
hmmm, has anyone verified that the fix supplied by 447571 actually fixes the bug 454118

I just examined the toolbar.xml file (per 447571) and the fix is in 3.0.2 but the original bug 454118 persists.

Please unmark this bug as a duplicate so that it can be reevaluated.

Thank you.
You need to log in before you can comment on or make changes to this bug.