MathML: msqrt is not properly displayed

RESOLVED WORKSFORME

Status

()

Core
MathML
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Roland Christophe, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071618 Iceweasel/3.0.1 (Debian-3.0.1-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071618 Iceweasel/3.0.1 (Debian-3.0.1-1)

If you try to display a mathml equation with "msqrt" tag, the size of the root is too small.

Reproducible: Always

Steps to Reproduce:
1.Display a mathml equation with "msqrt" tag like:
<msqrt>
    <mfrac>
        <mrow>
            <mn>2</mn>
        </mrow>
        <mrow>
            <mn>3</mn>
        </mrow>
    </mfrac>
</msqrt>
Component: General → MathML
Product: Firefox → Core
QA Contact: general → mathml
Version: unspecified → 1.9.0 Branch
Currently variable height roots are only supported with STIX Beta fonts

http://www.mozilla.org/projects/mathml/fonts/#1.9

Comment 2

9 years ago
Just curious if there is a reason Mozilla 1.9 can't use the MIT fonts if they're available and the STIX fonts aren't?  Seems like since Mozilla 1.8 could do variable height roots with the MIT fonts it that code could have been used as a fallback.
(In reply to comment #2)
For some of the fonts in the MIT bundle there are good reasons not to install the fonts.

https://bugzilla.mozilla.org/show_bug.cgi?id=161137#c39
https://bugzilla.mozilla.org/show_bug.cgi?id=400938#c0

A subset of the fonts could be safely installed and detected and special-cased as in Mozilla-1.8.  However, their handling has not been ported to the new gfx implementation, and effort would probably be better spent adding support for fonts that are likely to already be installed on the system such as Cambria Math (bug 372351) or OpenSymbol (from OpenOffice).

Downloadable fonts (bug 70132) could provide a way to ensure that some suitable font will be available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 4

7 years ago
Created attachment 481006 [details]
sqrt with non-stretched surd

I've just had this one bite me; it can be quite insidious.
Consider
<m:msqrt><m:mfrac><m:mi>&pi;</m:mi><m:mn>2</m:mn></m:mfrac></m:msqrt>
which displays like the attached image --- EASILY misread to
be quite a different quantity.

Now, I understand that the STIX fonts may be the only font
with stretchable surds, but is there any way to warn the user
that what they're reading is VERY wrong?

Frankly, it would be better to have the surd vertically centered
and disconnected from the overbar (ie a "broken display") than it
is to have the elegant but WRONG display... Landing craft have
crashed for reasons like this!
The fix for bug 414277 should mean that, even without STIX fonts,
Firefox 4 should not display this in a manner that looks wrong.
Depends on: 414277

Comment 6

7 years ago
Ah, thanks, Karl; looks like a good fix.
And it gives me a target, or answer "until firefox 4, be sure to install STIX"
You need to log in before you can comment on or make changes to this bug.