SM crashes when try to download file [@ nsString::ToInteger - nsTreeBodyFrame::PaintProgressMeter]

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: tobias, Assigned: Swatinem)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080908013336 Mnenhy/0.7.5.20005 SeaMonkey/2.0a1pre

SeaMonkey crashes reproduceable since yesterdays 2008090700xxxx Nightly-Build when I try to download a file to disk. 

I have tried to get a new Build from:
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
and after confirming filename and downloadlocation SeaMonkey crashes click O.K.-Button.

Disable the extra installed Add-Ons and delete the downloads.rdf will not help here. Add some Breakpad-IDs:

bp-09f42e85-7d96-11dd-8ffc-0013211cbf8a
bp-ef0db859-7d95-11dd-82ad-001cc45a2c28
bp-70a7d18c-7d91-11dd-ba9b-001a4bd43ef6
bp-3d316863-7d90-11dd-9592-001321b13766
bp-016b459e-7d85-11dd-84dc-001a4bd43ef6

Last known good was the 2008090605-Nightly-Build.

Updated

10 years ago
Assignee: nobody → arpad.borsos
Blocks: 452797
Component: Download & File Handling → Layout
Product: SeaMonkey → Core
QA Contact: download → layout
Summary: SM crashes when try to download file [@ nsString::ToInteger(int*, unsigned int) ] → SM crashes when try to download file [@ nsString::ToInteger - nsTreeBodyFrame::PaintProgressMeter]

Comment 1

10 years ago
confirming crash, also on FTP, so imho this would be a networking bug?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080907003401 SeaMonkey/2.0a1pre

crash from downloading ftp://ftp.mozilla.org/pub/ls-lR.gz
24902eca-7db4-11dd-a83a-001321b13766

1ff0514f-7db0-11dd-b7be-001a4bd43ed6	9/8/2008	4:23 PM
d8188654-7daf-11dd-b3a2-001cc4e2bf68	9/8/2008	4:21 PM
c4941919-7daf-11dd-ab82-001cc45a2ce4	9/8/2008	4:20 PM
94fa98b0-7daf-11dd-89fe-001a4bd43ef6	9/8/2008	4:19 PM
c9028363-7dae-11dd-8ee8-001321b13766	9/8/2008	4:13 PM
ae95cad4-6274-11dd-973b-001a4bd43ed6

Comment 2

10 years ago
please see dependent bug 452797 comment 5:
[this should be fixed in the next nightly build because] i've backed this out tip changeset: a5491c33992e because it caused [this] bug ....

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 3

10 years ago
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-09-06+00%3A00&maxdate=2008-09-07+00%3A00&cvsroot=%2Fcvsroot

This query is for 1.9.0, how can I do a query for 1.9.1?

crash is on opening or closing Download Manager:

I used the old preference panel for Downloads and specified a fixed folder, and
could download ftp://ftp.mozilla.org/pub/ls-lR.gz without crash

I'm also automatically downloading an update, without crash.
(Legacy PrefWindow)
  (Migrated: Browser)
      Downloads

When starting a download: Don't open anything
Automatically download files to specified download folder
(no crash using these settings)

crash-Setting:
When starting a download: Open the Download Manager

crashed when starting download to a fixed folder from downloading
ftp://ftp.mozilla.org/pub/ls-lR.gz
at opening Download Manager
e183f8e3-7dba-11dd-91ac-001cc45a2c28

Then I opened Download Manager manually, downloaded successfully,
but crashed when closing the download Manager manually
82952763-7dbb-11dd-b7dc-0013211cbf8a
(Reporter)

Comment 4

10 years ago
Verified=Fixed due Backout from Patch of Bug 452797, changeset a5491c33992e, have tested with several Tinderbox-Builds. THX for fixing this so quick.

(In reply to comment #3)
[..snip..CVS-Query..]
> 
> This query is for 1.9.0, how can I do a query for 1.9.1?

Afaik it was not possible to run Queries in hg at moment. If you have got an changeset-ID, you can find it adding "rev/[changeset-ID]" to the matching repository, take care if it was in mozilla-central or comm-central. Here it was:
http://hg.mozilla.org/mozilla-central/rev/a5491c33992e

I have filed Bug 447604 for fixing the "Todays Checkins" Query in Debug-QA-Menu to make it more easy to find the recent pushs/checkins into the Trunk, but there is more to do.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 454307
The stack from bug 454307 is very similar but on Linux.
OS: Windows XP → All
You need to log in before you can comment on or make changes to this bug.