disk cache collisions observed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: sandreas41, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080809 SeaMonkey/1.1.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20080809 SeaMonkey/1.1.11

I frequently visit Groklaw (http://www.groklaw.net) and the DotEarth blog (http://dotearth.blogs.nytimes.com/).
  Under Seamonkey 1.1.7 (the version I used just before the current one), I didn't see this; but I do now (using Seamonkey 1.1.11):
the image placed above the News Picks column on Groklaw, located at:
   http://www.groklaw.net/images/news_picks.gif
is being "retrieved" from the cache, but the actual image it's displaying is from:
   http://graphics8.nytimes.com/images/blogs/dotearth/_dotearth.png

It isn't always getting the same (wrong) image, though (although the same incorrect image is used in the session until I shift-Reload it).  I also visit other sites (such as http://www.romhacking.net/ ) which contain images, like the dragons on the RomHacking site.  At least once, the News Picks image on Groklaw had been replaced with that image, actually located at:
   http://www.romhacking.net/themes/fogel/fogel3.png

This is both annoying and confusing.  If it helps, I have not (yet) seen this error happen in reverse (i.e. the News Picks image doesn't take the place of either the dragon on the RomHacking page or the logo on the DotEarth pages); I (generally) visit these sites in the order RomHacking, Groklaw, DotEarth; and it doesn't happen every day -- I can reload the image specifically (View Image, shift-Reload, Back) and it'll be good... as far as I know, since I don't visit the Groklaw home page (which uses the image) more than once per day.  The problem seems to recur within a month; I can't really be more exact than that, I'm afraid.

Is there anything I can do to report back to you so this can be fixed?  This leaves me wondering if there are other cache problems that I'm simply not noticing...


Reproducible: Sometimes

Steps to Reproduce:
0. Visit a site that loads an image that is (apparently) misplaced into the cache.
1. Visit http://www.groklaw.net/

Actual Results:  
The "News Picks" image is incorrect.  The sources given above are two that I've been able to track down the original sources for.

Using "View Image" on the incorrect image shows that Seamonkey is "retrieving" the proper URL (i.e. the URL bar shows the right address), but the same incorrect image is displayed.


Expected Results:  
The correct image looks like a rolled-up paper with "Groklaw latest news picks" written on it.


JavaScript is always 'off' in the browser profile this has been seen in.
(The browser profile I use when I want to use JavaScript is set to automatically wipe the cache after every session, so I have no data on if this problem also occurs if JavaScript is 'on'.)


about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.2.3 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 4.2.3 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr/local/mozilla --enable-crypto --enable-ctl --enable-extensions --disable-installer --enable-application=suite --disable-gnomeui --disable-gnomevfs --disable-composer --disable-updater --enable-canvas --enable-svg --enable-svg-renderer=cairo --enable-strip --enable-reorder
new cache code
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.