Closed Bug 454424 Opened 14 years ago Closed 11 years ago

about:crashes should result in a page that explains crash reporter was disabled if it isn't available

Categories

(Core :: Networking, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 511713

People

(Reporter: timeless, Unassigned)

References

()

Details

(Whiteboard: [notacrash])

https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/246843

it seems on ubuntu today if you load about:crashes you probably get what you'd get if you loaded about:crashy in firefox

we should set it up so that if you disable breakpad, about:crashes
gives you a page explaining <whomever built this binary disabled crash
reporter, please complain to them and ask for help with reporting crashes>.

the fallback file would have to live somewhere outside of toolkit/crashreporter - i think this could just live in toolkit. it should always be built and shipped.

when crashreporter registers, it will have to register its to replace the default impl.
Bug 511713 is broader as it includes all OSes, not just Ubuntu (and this bug mentions XP :p ).  Hence, this bug should be marked as a dup.
Whiteboard: [notacrash]
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 511713
You need to log in before you can comment on or make changes to this bug.