Location bar prevents browser window from scaling smaller correctly

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: Daniel Roesler, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

When you decrease the size of a window where the location bar will shrink to its minimum size, the rendered page width will no longer shrink with the window width. In fact, even the scroll bar ceases to move with the page width.

Normally, this wouldn't occur, because Firefox's window will reach it's minimum width before the location bar does. However, if you move the location bar to a more restricted space, the location bar will reach it's minimum width before the window itself.

For example, say I want to move the location bar up to where the menu options are to clear up screen real estate. No big deal, just click customize and drag the location bar up there. But when I go to resize a window to make it smaller, the rendered html in the window won't shrink to the window size. It stays the same width as the minimum width location bar plus all of the other buttons' widths. The scroll bar also no longer scales with the window size, so I can no longer navigate up and down. Also, no side-to-side scroll bar appears to allow me to scroll sideways.

No other button or bar in the menu system has this same restricting effect.

I have attached a screenshot with several windows at different sizes illustrating what I mean. It might be kind of hard to explain in words, but the screenshot should help. To remove the location bar in several of the windows, I simply added it to and hid the Navigation toolbar.

Possible solutions:
-Make the location bar like all the other toolbar buttons and allow it to disappear without affecting the rendered width.
-Add a horizontal scroll bar when the window gets too small, so users can still navigate sideways.

Reproducible: Always

Steps to Reproduce:
1. Move the Location Bar to the topmost toolbar (i.e. where the menu options are).
2. Shrink the Firefox window width.
3. The rendered html and scroll bar section will stay the same width as the window gets smaller[1].

[1]-The location bar must have reached it's minimum width for the rendered window to no longer decrease width.
Actual Results:  
The up-down scroll bar disappears and users cannot scroll side-to-side to see the now-hidden content.

Expected Results:  
Either the rendered section width should resize with the window, or a side-to-side scroll bar should appear to allow horizontal scrolling.

This test was performed on Firefox 3.0.1
(Reporter)

Comment 1

10 years ago
Created attachment 337691 [details]
Example windows illustrating the resize bug. Note highlighted sections.
(Reporter)

Comment 2

10 years ago
I just tested it with Ubuntu Linux, and this bug does NOT appear in Firefox 3.0.1 for Ubuntu Linux (firefox 3.0.1+build1+nobinonly-0ubuntu2 package).
(Reporter)

Comment 3

9 years ago
This bug still exists on Windows version 3.5.1.

Comment 4

9 years ago
I can confirm this bug on OS X 10.5.8, Firefox 3.5.5.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-1-30]
Version: unspecified → 3.5 Branch
(Reporter)

Comment 6

8 years ago
The bug appears to be fixed for http but not https.

See the example screenshot:
http://i.imgur.com/kZZdw.png
(Reporter)

Comment 7

8 years ago
Created attachment 500971 [details]
http resizes correctly but https does not [3.6.13 for XP]

This is the same screenshot as the previous comment.
Attachment #337691 - Attachment is obsolete: true
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 9

8 years ago
I did reply with screenshots. The bug appears to be fixed for http, but not https.
Status: RESOLVED → VERIFIED

Comment 10

8 years ago
See following screenshot for verification of OPEN bug with FF 3.6.13 on OS X 10.6.6.

http://i.imgur.com/Ui6x6.png

Crucial note: I reproduced this bug ONLY on first page load of the google page after starting Firefox, (independently of wether it was a http or https connection), and then resizing the screen. Once I entered a search term, the scroll bars appeared and were displayed correctly. Not sure how this varries from URL to URL. This seems to be related in some way to initialization of the scroll bars (lazy init?), and not there general functioning.

Comment 11

8 years ago
Erratum: above test was done without an empty profile. Using a new profile I could not reproduce the bug. Possibly an issue with some FF plugin :(
(Reporter)

Comment 12

8 years ago
Created attachment 509530 [details]
Shows https resize bug with new profile

Sam Spycher: I have attached a screenshot that shows the bug for HTTPS ONLY in a new profile. This bug is present in Windows XP and Ubuntu for Firefox 3.6.13. Are you unable to recreate this only in OSX?
(Reporter)

Comment 13

8 years ago
Sam Spycher: For me, this bug occurs on any https page loaded within the new profile (including this bug page). Can anyone reproduce the bug using this bug page's url (https://bugzilla.mozilla.org/show_bug.cgi?id=454425)?
(Reporter)

Updated

8 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 14

8 years ago
Hi Daniel

I am unsure if your screenshot demonstrates non-existence of the bug for http. If you reduce the http page even further, doesn't the vertical scroll bar stop moving with the diminishing window width as well? There does seem to be a difference in that the https page has the domain name next to the favicon, which makes the URL bar wider, and therefore the vertical scroll bar disappears earlier.

See my screenshot for disappearing scrollbars and non-rerendering of the page for http and https connections:

http://i.imgur.com/Sivub.png

I would concur that this is a bug, since there is no good reason why the page should not be rerenderd, and especially no good reason a scroll bar should _ever_ dissappear behind a window border, simply because the nav elements don't fit into the window anymore.

P.S. Sorry for messing up your bug report. In the above posts I was describing a completely different issue where no scroll bars appear at all. This seems to be because of some plugin, since it doesn't happen with a new profile.

Comment 15

8 years ago
P.P.S Chrome "solves" this issue by not allowing the page to decrease in width to less than the minimal width of the nav bar elements.

Personally, I prefer the (unfortunately buggy) FF approach of allowing the page width to be decreased right up to the minimal width of the window control elements. It's great for testing. Also, the browser as a generic container has no business in prescribing a minimal window width beyond what is absolutely necessary for window control. Funny, of all browsers I would have expected Chrome to respect that.
Does this happen with Firefox 4 final?
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 17

7 years ago
Yes, it does, please see the attached screenshot. Again, this now only happens with https. It works fine with http.

Can no one confirm this?! I feel like this is super easy to confirm...
(Reporter)

Comment 18

7 years ago
Created attachment 532516 [details]
Firefox 4.0.1 screenshot of bug occurring on https

Comment 19

7 years ago
I confirm :

- existence of bug for Firefox 4.0.1 on OS X, working with an empty profile
- that it is dead simple to reproduce. Tested on http://www.google.com and https://encrypted.google.com.

@Daniel: are you sure it is only for https for you? On my computer the bug does not depend on http or https, the only difference is that it appears earlier for https (ie at greater screen widths), because the https location bar has an additional domain indication before the URL (see the blue "google.com" on my screenshot), making the URL bar wider, and therefore causing the bug to appear earlier.

http://imgur.com/4HdpR
(Reporter)

Comment 20

7 years ago
Created attachment 532741 [details]
Menu bar missing also causing the bug.

I cannot confirm your http problem on my WinXP version. It is only https for me. However, there is another trigger that will cause the problem. When disabling the menu bar, the firefox dropdown at the the top will cause the same issue when the window is resized below the dropdown_width + min/max/close icon_width.

I've attached a screenshot displaying the problem caused by https and/or the firefox dropdown.
(Reporter)

Comment 21

4 years ago
Found this issue to still be open. It appears to be fixed, though not sure when. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.