Selected argument in option tags not respected on reload

RESOLVED DUPLICATE of bug 201056

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 201056
9 years ago
9 years ago

People

(Reporter: Cork, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080909020352 Minefield/3.1b1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1pre) Gecko/20080909020352 Minefield/3.1b1pre

If a selection box has several options with the same value, the selected argument isn't respected.

Reproducible: Always

Steps to Reproduce:
1. Load the testcase.
2. Press Reload.
Actual Results:  
The select box shows "WRONG"

Expected Results:  
The select box shows the same as when you first load it. Namely "Correct".

Also tested on Win Vista 3.0.1 and Nightly 2008-09-08.
(Reporter)

Comment 1

9 years ago
Created attachment 337713 [details]
Testcase of the selectbox
(Reporter)

Updated

9 years ago
Keywords: testcase
Version: unspecified → Trunk
(Reporter)

Updated

9 years ago
OS: Linux → All
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 201056
You need to log in before you can comment on or make changes to this bug.