Auto-repeat button becomes current selection in menulist

RESOLVED FIXED

Status

()

Core
XUL
P4
normal
RESOLVED FIXED
18 years ago
10 years ago

People

(Reporter: Nikhil Bhatla (gone), Assigned: David Hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3+)

(Reporter)

Description

18 years ago
In this morning's MOzilla build (7/13):

While in a menulist with auto-repeat buttons, if you mouse over the auto-repeat 
button to scroll through the popup list, it becomes the current selected item in 
the list.  So now, if you click outside the menulist popup without making a 
selection, you have an empty string as the current selection instead of the 
previous selection's text.

For example, drop your resolution to 800x600 and go to the fonts prefs panel.  
Click on a font menulist.  Mouse over an auto-repeat button, and you'll see that 
the current selected text in the menulist box (not in the popup) disappears.  
This occurs both in modern and classic Mac, and I presume in Windows and Linux 
as well.
nominating for beta3. while i can't dupe it on win32 (not enough fonts on my
system), I'm sure it happens since there is no native code in the menulist.
Status: NEW → ASSIGNED
Keywords: nsbeta3
OS: Mac System 9.0 → All
Hardware: Macintosh → All
Target Milestone: --- → M20

Comment 2

18 years ago
should affect very few users, can cancel, low priority.  what happens to the 
font selection when this happens?
Priority: P3 → P4
Whiteboard: nsbeta3+

Comment 3

18 years ago
->hyatt
Assignee: hyatt
Status: ASSIGNED → NEW

Comment 4

18 years ago
*** Bug 44451 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Nikhil - just out of curiosity what is an auto-repeat button?

Comment 7

17 years ago
It's the up/down arrow on an autoscrolling menulist -- for example if you have 
a really long bookmarks list, or for the example that Nikhil notes at the top
of this bug report.

Comment 8

17 years ago
verified on NT & 98 using 2000-11-08 NS6

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.