event.ctrlKey, event.shiftKey and event.altKey are undefined with DOMMouseScroll event

RESOLVED FIXED

Status

()

Core
DOM: Events
--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Alice0775 White, Assigned: smaug)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3pre) Gecko/2008090906 GranParadiso/3.0.3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3pre) Gecko/2008090906 Firefox/3.0.1

Ctrl + Mouse Wheel does not define event.ctrlKey property.
Shift and Alt key also.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox
2.Go any page.
3.Ctrl + Mouse Wheel on the content area.
Actual Results:  
event.ctrlKey property is undefined.

Expected Results:  
event.ctrlKey property should be set to true.

This issue causes the problem that mouse wheel zoom level will not be stored.

Works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3pre) Gecko/2008090906 GranParadiso/3.0.3pre

Not Works
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080909105611 Minefield/3.1b1pre
(Reporter)

Comment 1

10 years ago
Created attachment 337746 [details]
Test case of userChrome.js script.

This is Test case for userChrome.js.
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
Regression window:

Works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080812045727 Minefield/3.1a2pre


Not Works:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080813032636 Minefield/3.1a2pre
(Reporter)

Comment 3

10 years ago
To lack information of the event.ctrlKey, the following problems occur.

If Browser.zoom.Sitespecific is true,
Zooming by scroll-wheel to a larger/smaller zoom, switching to another tab and then switching back to the zoomed tab will reset the zoom level to the previous one.

(Zooming by pressing "Ctrl" + "=" works fine. Setting "Browser.zoom.Sitespecific" to false and scrolling zoom levels in individual tabs works fine.)
(Reporter)

Comment 4

10 years ago
Created attachment 337842 [details]
Test case
(Reporter)

Comment 5

10 years ago
Created attachment 337843 [details]
Test case
Attachment #337842 - Attachment is obsolete: true
(Reporter)

Updated

10 years ago
Blocks: 378028
Keywords: regression
Status: UNCONFIRMED → NEW
Component: General → DOM: Events
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → events
Hardware: PC → All
Flags: blocking1.9.1?
(Assignee)

Updated

10 years ago
Assignee: nobody → Olli.Pettay
(Assignee)

Comment 6

10 years ago
Created attachment 337860 [details] [diff] [review]
add nsIDOMMouseEvent to classinfo
Attachment #337860 - Flags: superreview?(roc)
Attachment #337860 - Flags: review?(roc)
(Reporter)

Comment 7

10 years ago
Bug 454460 seems to be related to this bug.
Attachment #337860 - Flags: superreview?(roc)
Attachment #337860 - Flags: superreview+
Attachment #337860 - Flags: review?(roc)
Attachment #337860 - Flags: review+
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Flags: blocking1.9.1?

Updated

10 years ago
Blocks: 453429
Duplicate of this bug: 453429
Bug 350471 added tests for this bug.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.