Sent email appears in the Sent folder, but the content is blank or it is content from various mail sent months ago

RESOLVED INVALID

Status

Thunderbird
General
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: david, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: version 2.0.0.16 (20080708)

Beginning 8/28/08 all messages sent are blank when viewed from the Sent folder.  All email prior to that date are readable, but all mail sent and stored in the Sent folder is void of content... or the content is a scrambled mess of caricatures or various sentences from very old email.  Most of the time, the body is blank although the addressing etc. is there. 

Reproducible: Always

Steps to Reproduce:
1.Email is sent
2.I confirm or refer to a sent email only to find it blank
3.


Expected Results:  
Email content should be viewable, always has been over the years and now suddenly...it's all gone

Comment 1

10 years ago
What did you do on that date that could have done this. Anything from installing a program, to updating Thunderbird. Also, try starting in safe Mode.
Version: unspecified → 2.0
(Reporter)

Comment 2

10 years ago
I shut my computer down and left town on 8/27/08 for a week.  There was no one here to use it and as I usually do when I leave town for any length of time, I removed the hard drive and stored it in a safe place.  As far as I know there was not an update done unless it happened when I restarted my computer upon my return, 9/2/08

Comment 3

10 years ago
Have you tried starting in Safe Mode, and look in your profile folder at those messages.
(Reporter)

Comment 4

10 years ago
Yes I have entered Safe Mode and checked the Sent message folder in my profile, no change.  What is bazaar is some of the emails in my Sent folder are blank while others contain content from January of 2005.  Strange thing is I do not have any saved messages beyond early 2008.  I have not been able to find where it is pulling the content from.  Can I forward you one of these so you can see what I am talking about and maybe find where it's pulling the content from?

Comment 5

10 years ago
Does "Rebuild index" in the folder properties help?
BTW, the mails are in your profile folder in the file named "Sent" (no extension) - http://kb.mozillazine.org/Profile_folder 

Might also try deleting Sent.msf (which is the fast index file).
(Reporter)

Comment 6

10 years ago
Rebuilding index and deleting sent.msf has no affect... problem still exists.  This method of technical support is archaic and taking too long to find the problem... if we can find the problem that is.  My business requires me to retain every sent e-mail and losing them is putting me at great risk if required to show proof of contact.  I need immediate help here.

Comment 7

10 years ago
David,
This is not a technical support center. This is a technical bug reporting database for the developers. You will not receive technical support here. For support, use http://support.mozilla.com and http://support.mozilla.com/forums.
(Reporter)

Comment 8

10 years ago
I shall go back to the forum for help, but most likely will go back to Outlook Express as I had given up on the forum which is why I reported this bug.  Seems others have had this problem and so far I find no answers to them on the forum either.  Hopefully someone can fix this bug.

Comment 9

10 years ago
The "Sent" file if just text so you can open it e.g. with wordpad and verify if the text is actually wrong on disk or not.
(Reporter)

Comment 10

10 years ago
There is nothing in the notepad.  I sent an e-mail to a client this morning with an attachment, he received it just fine, but when I view it in my Sent Folder I find random text from an e-mail sent June 8, 2005 which was long ago deleted.  This is really puzzling to me to find partial content of an email deleted years ago... where in the world is my Sent Folder finding this stuff and why?  Talk about a BUG in the new 2.0.0.16 version.  I've tried the Forums, no one responded to my issue but I have seen others are experiencing this as well.
Those old e-mails are not anywhere in your computer? You could try searching for them to see where they are going. Magnus, does it seem like one of the folders got mixed somehow with an older one?
Reporter, please go to http://kb.mozillazine.org/Disappearing_mail and try to find those old e-mails with the steps in the article.
(Reporter)

Comment 13

10 years ago
It appears the problem is solved.  The Sent Folder although empty of any readable mail, was retaining years of deleted email.  After using Compact to clean the folder, sent mail is now readable.  The function named "Compact" really should be renamed to something like "Clean" or "Format".  When you use a heading like Compact it causes one to think Compress rather than Clean.  Anyway, Sent Folder is now "clean" of all old deleted mail and problem solved.  So "bug guys"... change the name of the "Compact" function to something more appropriate.
Please, only one bug report per bug. also, compact does compact the files, as in compressing. It removes those deleted e-mails. http://kb.mozillazine.org/Thunderbird_:_Tips_:_Compacting_Folders.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.