The default bug view has changed. See this FAQ.

Contexts menu for links in emails "Copy Link Location" and "Copy" both uses C as accesskey

RESOLVED FIXED in Thunderbird 19.0

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: dholbert, Assigned: Magnus Melin)

Tracking

Trunk
Thunderbird 19.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
One of the changes between Firefox 2 and Firefox 3 was that the hotkey for  "Copy Link Location" changed from "c" to "a".  However, in Thunderbird, it's still "c".  Thunderbird should change to match Firefox.

Steps to reproduce:
 1. View an email that includes a hyperlink
 2. Right-click the hyperlink
 3. Press 'a'

EXPECTED RESULTS:
"Copy Link Location" should be chosen

ACTUAL RESULTS:
"Select All" is chosen

Note: In Firefox 3, 'Select All' doesn't even appear in hyperlink context menus *at all*, which removes the ambiguity.  It does appear in non-hyperlink context menus, though, and 'a' maps to Select All in those menus.

Tested using Shredder version 3.0a2 (2008072418) on Ubuntu Linux 8.10a5

Comment 1

6 years ago
This is still true, and still relevant -- I actually use this feature in Firefox, and it annoys me slightly in Thunderbird.
Severity: normal → enhancement
Summary: Contexts menu for links in emails should map hotkey 'a' to "Copy Link Location", matching Firefox 3 → Contexts menu for links in emails should map access key 'a' to "Copy Link Location", matching Firefox 3

Comment 2

5 years ago
We should definitely do this, since Copy and Copy Link Location are using the same access key. To see this in action, select some text (any text) and then right-click on a link.
Whiteboard: [good first bug]
(Assignee)

Comment 3

5 years ago
"a" is already used for "Select All". L seems to be free though
Summary: Contexts menu for links in emails should map access key 'a' to "Copy Link Location", matching Firefox 3 → Contexts menu for links in emails "Copy Link Location" and "Copy" both uses C as accesskey
(Assignee)

Comment 4

5 years ago
Created attachment 667147 [details] [diff] [review]
proposed fix
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #667147 - Flags: review?(squibblyflabbetydoo)

Comment 5

5 years ago
Comment on attachment 667147 [details] [diff] [review]
proposed fix

rs=me. Sorry about the delay!
Attachment #667147 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/comm-central/rev/303a9adae549 -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
You need to log in before you can comment on or make changes to this bug.