add Microsoft Active Accessability, (MSAA) to enhance usability for disabled users who use access technology.

VERIFIED DUPLICATE of bug 12952

Status

P3
enhancement
VERIFIED DUPLICATE of bug 12952
19 years ago
14 years ago

People

(Reporter: rshugart, Assigned: bdonohoe)

Tracking

({verifyme})

Trunk
x86
Windows 98
verifyme

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 95)
BuildID:    all

MSAA is a series of APIs produced by microsoft that allow access technology 
such as screen readers and magnification software to communicate with 
mainstream applications and get information regarding what is displayed on the 
screen.  By making use of MSAA, Mozilla would become a lot more usable to users 
of access technology.  

Reproducible: Always
Steps to Reproduce:
1.
2.
3.NA

Expected Results:  						
	Assumming Mozilla had MSAA, it should communicate with a screen reader 
and/or other access technology.  The access technology would then render the 
page as appropriate.  

More information on MSAA can be found at Microsoft's accessability page.  The 
url is http://www.microsoft.com/enable.  The only current browser that makes 
use of MSAA is Internet Explorer.  Two access products that use MSAA and have 
downloadable demos are Jaws for Windows at http://www.hj.com and Windoweyes at 
http://www.gwmicro.com.

Comment 1

19 years ago
MSAA is a MS-only technology which only runs on certain versions of Windows.
Mozilla is a cross-platform browser which cannot be tied to a certain platform's
features. While I agree that Mozilla could use something like MSAA, now is
hardly the time to consider it, as there are plenty of bugs around to make the
browser unusable for people that don't use MSAA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
Just because something works only on certain versions of a particular operating 
system is not reason in itself not to support it. Mozilla supports Internet 
Config, for example, which works only on certain versions of Mac OS.

CCing Lake and Peter for verification. From reading Microsoft's site, it looks 
like it just *might* be possible to implement MSAA using a utility which reads 
the XUL and generates the appropriate COM events. In that case, this could be 
resolved as MUCH LATER rather than WONTFIX.
Keywords: verifyme
OS: Windows 95 → Windows 98
This is a dup ...
Status: RESOLVED → UNCONFIRMED
Keywords: verifyme
Resolution: WONTFIX → ---

*** This bug has been marked as a duplicate of 12952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago19 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE

Comment 5

19 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.