text that should appear on one line is split into two rows

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Jey Kottalam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080910020330 Minefield/3.1b1pre

The second entry of the "References" section is split into two parts, with the second half rendered one line above where it should appear.

Reproducible: Always

Steps to Reproduce:
1. Visit http://en.wikipedia.org/w/index.php?title=GMAC&oldid=236366435
2. Look at Reference #2

Actual Results:  
text is rendered on two lines instead of one

Expected Results:  
render text on a single line

I also reproduced this with the following builds: 
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
(Reporter)

Comment 1

9 years ago
Created attachment 337922 [details]
screenshot demonstrating
This seems to be deliberate: the references are in a <div> with style="-moz-column-count: 2;"
See http://en.wikipedia.org/wiki/Template:Reflist and http://en.wikipedia.org/wiki/Template_talk:Reflist for more information.

Comment 4

9 years ago
(In reply to comment #2)
> This seems to be deliberate: the references are in a <div> with
> style="-moz-column-count: 2;"

This is a unfortunate case, but no bug.

(In reply to comment #3)
> http://en.wikipedia.org/wiki/Template_talk:Reflist for more information.

The problem discussed there is bug 422089.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.