bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

TM: Crash if user clicks on 'Manage Search Engines...' with JIT enabled [@js_ExecuteTree]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: Joris de Haes, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080909032504 Minefield/3.1b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080909032504 Minefield/3.1b1pre

When expanding the list of search engines I get the full list. I want to organize them (group Wikipedia's, dictionaries and Mozilla's together) so I need to open the search engines manager. When I click on 'Manage Search Engines...' Minefield crashes.

Reproducible: Always

Steps to Reproduce:
1. Click on the current search engine icon to the expand list of search engines
2. Click on 'Manage Search Engines...' to open the search engine manager
Actual Results:  
I get a Windows XP error-message saying the program has been closed and Microsoft is sorry for that. I don't get to see Breakpad :( and I don't get the option to restore the session. When I restart Minefield I get the option to restore the session, which works fine.

Expected Results:  
Show 'Manage Search Engine List' with all the search engines.

Environment:
Nightly Minefield download (not compiled) for win32. Windows XP uses 'classic' theme. Minefield uses default theme. No Talkback crash ID
(Reporter)

Comment 1

10 years ago
Created attachment 337953 [details]
about:buildconfig
Do you have javascript.options.jit.chrome enabled? This sounds like bug 452208, though that was supposedly fixed.
(Reporter)

Comment 3

10 years ago
You are right. I had jit enabled.

Scenarios I just tried:

1 Starting with jit.chrome true and jit.content true. Click = Crash
2 Starting with jit.chrome true and jit.content false. Click = Crash
3 Starting with jit.chrome false and jit.content true. Click = No Crash
4 Starting with jit.chrome false and jit.content true. Click = No Crash
5 Starting with jit.chrome enabled and changing it to false after startup. Click = No Crash
6 Starting with jit.chrome true and changing it to false. Use the search engine list to change search engine but don't use the manager. After that change jit.chrome back to true. Click = Crash

My conclusion: If the first time the search engine manager is used with jit.chrome false there is no crash. When the first time it is used with jit.chrome true it crashes. Changing jit.chrome state after startup from true to false avoids crashing.

Comment 4

10 years ago
I got this report:
bp-10b707fa-7fa0-11dd-b9d4-001321b13766
That looks like a different stack than bug 452208.
Assignee: nobody → general
Component: Search → JavaScript Engine
Product: Firefox → Core
QA Contact: search → general
Summary: Crash if user clicks on 'Manage Search Engines...' → Crash if user clicks on 'Manage Search Engines...' with JIT enabled [@js_ExecuteTree]

Comment 6

10 years ago
Signature	js_ExecuteTree
UUID	10b707fa-7fa0-11dd-b9d4-001321b13766
Time	2008-09-10 18:22:16-07
Uptime	15
Product	Firefox
Version	3.1b1pre
Build ID	20080910043000
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 15 model 3 stepping 4
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x697463a1
Comments	
Crashing Thread
Frame 	Module 	Signature 	Source
0 	js3250.dll 	js_ExecuteTree 	
1 	js3250.dll 	js_MonitorLoopEdge 	
2 	js3250.dll 	js3250.dll@0x65ec0 	
3 	js3250.dll 	js_Invoke 	
4 	js3250.dll 	array_extra 	
5 	js3250.dll 	array_map 	
6 	js3250.dll 	js_Interpret 	
7 	js3250.dll 	js_Invoke 	
8 	js3250.dll 	JS_CallFunctionValue 	
9 	xul.dll 	nsJSContext::CallEventHandler
Keywords: crash
(Reporter)

Comment 7

10 years ago
Are those links to _my_ crash report? If so, I'd like to note that my OS version is XP SP3, and the the time is weird... can anyone tell/link me info about the time format? what timezone, 12/24 hours, offset, DSL?

Back on the topic: can I do anything to help now, or do I wait for the next nightly build? :)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080911082840 Minefield/3.1b1pre

I don't get this crash.

Updated

10 years ago
Summary: Crash if user clicks on 'Manage Search Engines...' with JIT enabled [@js_ExecuteTree] → TM: Crash if user clicks on 'Manage Search Engines...' with JIT enabled [@js_ExecuteTree]

Comment 9

10 years ago
no, they're brian's (comment 4). i can't easily get your crash reports, you could load about:crashes and provide them here.

Comment 10

10 years ago
No crash using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080912031847 Minefield/3.1b1pre

Comment 11

10 years ago
Well only my normal profile crashes even with today's build.  No problems with a clean profile.  But my normal profile crashes even in safe mode with my plugins also disabled.  I'll have to dig deeper to see if I can find the cause.

Comment 12

10 years ago
Ok I got it.  It 's the searchplugins. Not a surprise given what triggers the crash.   It doesn't seem to be any search plugin in particular.  It seems like anytime I have 5-7 plugins in that directory in the profile is when it crashes.  So that's 5-7 extra plugins without counting the default plugins.  I have 7 plugins in the program's searchplugins directory.
(Reporter)

Comment 13

10 years ago
That could explain it. I normally have 35 searchplugins. (They are really useful)
Yesterday I removed Firefox 3.0.1, Shiretoko and Minefield 3.1b1pre and reinstalled the latest nightly binary for win32. I kept my profile.
With a clean profile I can add the same amount of plugins and it doesn't crash. After that I tried it back with my normal profile. Started up with jit enabled and the same searchplugins as in the bugdescription and everything went fine; no crash. So either this bug is fixed or I cannot reproduce it anymore.
I can reproduce the bug on Mac OS X.5 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr-FR; rv:1.9.1b1pre) Gecko/20080912020659 Minefield/3.1b1pre ID:20080912020659
When I click 'Manage Search Engines...', it crashes instantly.

Here is an about:crashes that I get: http://crash-stats.mozilla.com/report/index/8078eb7a-81c7-11dd-9bd7-001cc4e2bf68?p=1

Comment 15

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080914034157 Minefield/3.1b1pre

I can't install the additional plugins from addons.mozilla.org:
This XML file does not appear to have any style information associated with it. The document tree is shown below.
      
I installed bugzilla and addons as additional search engines, and tested all buttons of 'Manage Search Engines...', moved, removed, set keyword, saved, canceled etc. no crash seen

Comment 16

10 years ago
Created attachment 338706 [details]
zip of profile search plugins

does anyone else crash with these search plugins in a new profile with chrome jit?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Blocks: 453668

Comment 17

10 years ago
No crash using attached search plugins in nightly Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081006 Minefield/3.1b1pre 20081006034237

Some recent code changes fixed this?

Comment 18

10 years ago
I concur using the same build.  

->WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@js_ExecuteTree]
You need to log in before you can comment on or make changes to this bug.