dbtests.sh and fips.sh have hard-coded error code that breaks testing

RESOLVED DUPLICATE of bug 447563

Status

NSS
Tools
P1
blocker
RESOLVED DUPLICATE of bug 447563
9 years ago
9 years ago

People

(Reporter: Elio Maldonado, Unassigned)

Tracking

unspecified
3.11.2
All
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 338010 [details] [diff] [review]
patch for debtests to fix failures

Quote from  Bug 447563 
With this fix pk11 returns a different error code and one unused error code was removed from err.h. Ddtest in turn returns a different error code (one less than before) but the dbtests.sh and fips.sh scripts have the expected error code hard-coded to 46. It's now 45.  Patches for dbtests.sh fips.sh that should fix this failures is attached.
(Reporter)

Comment 1

9 years ago
Created attachment 338011 [details] [diff] [review]
patch for fips test to fix failuers
(Reporter)

Updated

9 years ago
Severity: critical → blocker
Priority: -- → P1
(Reporter)

Updated

9 years ago
Blocks: 447563

Comment 2

9 years ago
Please consider the solution I proposed in bug 447563 comment 12.
(Reporter)

Comment 3

9 years ago
Yes, solving it via changes in bug 447563 is the proper way. Marking this as duplicate of 447563 and resolved.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447563
You need to log in before you can comment on or make changes to this bug.