Keyboard does not work at all!

VERIFIED FIXED

Status

()

Core
Keyboard: Navigation
P3
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Wolfgang Streule, Assigned: Jeffrey S. Kobal)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Tried M17p2 binaries on 4 Systems (Warp3 FP 42 / Warp4 FP 12, both german), but 
the Keyboard did not allow me anything to be typed in (expect the del-key). Had 
the same problem with M17p1 and M16.

Comment 1

18 years ago
Please ensure that your keyboard is plugged in.  Most need a source of power 
before they can properly function.

cc'ing mike kaply, the IBM / OS/2 guy.

Comment 2

18 years ago
What keyboard layout are you using?

If you go to:

System -> Settings -> Keyboard

and change to  "German 453", it should work.

We are investigating the problems.

Comment 3

18 years ago
Save problem with Swiss German keyboard. "German 453" layout isn't an 
acceptable solution, many keys have different codes.

Comment 4

18 years ago
Please check your CONFIG.SYS.

On the DEVINFO=KBD line, does it have GR or DE? If it is GR, please change it to 
DE.

Comment 5

18 years ago
I'd like to confirm that this bug appears on my Warp 4 US fp12 with 
Finnish keyboard setting too. It completely prevents using Mozilla.
I can delete but not type in or cut/paste anything on the URL line.
I can copy text from the URL document itself but not from the URL
location line. I remember having the same problem with Gecko for OS/2
about 1.5 years ago.

My config.sys reads 
SET LANG=FI_FI
DEVINFO=KBD,SU,D:\OS2\KEYBOARD.DCP
CODEPAGE=850,437
...these are default settings when using a Finnish keyboard.

confirming since several users have seen it. however, over to teruko for
i18n/l10n qa.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → teruko

Comment 7

18 years ago
This is definitely OS/2 only, so it should stay in our bucket.

We are probably going to rewrite our OS/2 keyboard interface to workaround this 
problem.
(Assignee)

Comment 8

18 years ago
For Finnish, try changing your keyboard line in CONFIG.SYS to:
DEVINFO=KBD,FI,D:\OS2\KEYBOARD.DCP

Comment 9

18 years ago
over to mkaply, OS/2 stuff
Assignee: don → mkaply

Comment 10

18 years ago
Nobody has this one right now
Assignee: mkaply → nobody

Comment 11

18 years ago
>For Finnish, try changing your keyboard line in CONFIG.SYS to:
>DEVINFO=KBD,FI,D:\OS2\KEYBOARD.DCP
This does not help. In addition the useful undocumented(?)codepage
setting 850,1004 (for Windows cp texts) cannot be used.

Comment 12

18 years ago
Yes, the workarounr for german keyboard in a german OS/2 is 
to change 
DEVINFO=KBD,GR,D:\OS2\KEYBOARD.DCP
to
DEVINFO=KBD,DE,D:\OS2\KEYBOARD.DCP
(one have to boot)

_AND_ 

system->keyboard (tastatur) to Deutschland (435)

(this can be done during runtime without booting and can be 
switched back, so it is possible to do some test with 
Warpzilla)

Comment 13

18 years ago
Any change with the nightly build?

Updated

18 years ago
Assignee: nobody → jkobal

Comment 14

18 years ago
This is going to be our "rewrite the keyboard" bug.

I'm assigning it to jkobal

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 15

18 years ago
Created attachment 15639 [details] [diff] [review]
Rewrite of keyboard stuff to do the right thing

Comment 16

18 years ago
As the patch is contained entirely within an OS/2 specific portion of the tree,
I'm going to assume that you know what you're doing. :-) r=cls

Comment 17

18 years ago
Fix has been checked in - will be in next nightly build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
With the 00-9-29 build immediately when I touch a key in order to type into the
URL field I get:

SYS1375
A prog generated an access violation at 1b2d4c06
NGLAYOUT.DLL 001:003c4c06
P1=00000001 P2=00000000 P3=XXXXXXXX P4=XXXXXXXX
EAX=00000000 EBX=00000000 ECX=00000001 EDX=017d75d0
ESI=0103ba58 EDI=0103bab0
DS=0053 DSACC=d0f3 DSLIM=1fffffff
ES=0053 ESACC=d0f3 ESLIM=1fffffff
FS=150b FSACC=d0f3 FSLIM=00000030
GS=0000 GSACC=**** GSLIM=*******
CS:EIP=005b:1b2d4c06 CSACC=d0df CSLIM=1fffffff
SS:ESP=0053:0103B838 SSACC=d0f3 SSLIM=1fffffff
EBP=0103b938 FLG=00012202

Happens whether the key is a letter, backspace or del key.
Typing into other fields seems ok.
Warp system is as explained in an earlier message. 

So from my point of view behavior has changed but not improved.
I'm happy to see you're trying so hard to fix this :)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 20

18 years ago
*** Bug 54862 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
Fix has been checked in. We were missing a new HTML bindings file.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
I tested this using the 2000100309 build - it works beautifully !
(Jumps up and down excitedly, dances a jig around portable
computer). Thank you for fixing this, now we Europeans can begin
using Warpzilla ! I'm impressed with this bug handling system - 
it's very professional :)

Comment 23

17 years ago
Per comments in bug - works good.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.