TM: "Assertion failure: PCVAL_IS_SPROP(entry->vword)" with getter

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jruderman, Assigned: brendan)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
js -j 
js> this.__defineGetter__('x', function() 2); for (var j=0;j<4;++j) { x=1; }

Assertion failure: PCVAL_IS_SPROP(entry->vword), at jstracer.cpp:4441
(Assignee)

Comment 1

10 years ago
See bug 454689 and bug 454590 -- probably should dup but I want to patch first.

/be
(Assignee)

Comment 2

10 years ago
Created attachment 338054 [details] [diff] [review]
fix

Gonna land this on r=me authoritay.

/be
Assignee: general → brendan
Status: NEW → ASSIGNED
Attachment #338054 - Flags: review+
(Assignee)

Comment 3

10 years ago
Fixed:

http://hg.mozilla.org/tracemonkey/rev/d01bf8dcae43
http://hg.mozilla.org/mozilla-central/rev/3a3f258dd951

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Duplicate of this bug: 454590

Updated

10 years ago
Blocks: 451986

Comment 5

10 years ago
/cvsroot/mozilla/js/tests/js1_5/extensions/regress-454744.js,v  <--  regress-454744.js
initial revision: 1.1

m-c: changeset:   19328:ae5a6fe1d588

The browser test throws TypeError: setting a property that has only a getter
Flags: in-testsuite+
Flags: in-litmus-

Comment 6

10 years ago
This test should have been in the 1.8 suite.

RCS file: /cvsroot/mozilla/js/tests/js1_8/extensions/regress-454744.js,v
done
Checking in js1_8/extensions/regress-454744.js;
/cvsroot/mozilla/js/tests/js1_8/extensions/regress-454744.js,v  <--  regress-454744.js
initial revision: 1.1
done
Removing js1_5/extensions/regress-454744.js;
/cvsroot/mozilla/js/tests/js1_5/extensions/regress-454744.js,v  <--  regress-454744.js
new revision: delete; previous revision: 1.1
done

http://hg.mozilla.org/mozilla-central/rev/af3f816c35d2
You need to log in before you can comment on or make changes to this bug.