Closed Bug 454765 Opened 14 years ago Closed 14 years ago

Uploaded files are locked by Firefox

Categories

(Firefox :: File Handling, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 183689

People

(Reporter: ian.beveridge, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

If I upload a file on a web form (This is on a company intranet, so I can't supply an example URL), then the file is uploaded just fine. If I then go to alter that file (It's a zip file, generated by a command-line utility) then the creation fails because FF has a lock on the file.

The lock persists even if I close the tab that holds the result of the form submission. The only way I can re-generate the file is by closing FF and starting it again to release the lock.

Reproducible: Always

Steps to Reproduce:
1.Upload file
2.Alter file
3.Cannot save file because FF has a lock.
Actual Results:  
Locked file.

Expected Results:  
Expected FF to release the lock.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
You need to log in before you can comment on or make changes to this bug.